the system stopped detecting the microphone (everything works on another system)

Something happened, and when I open the system settings and go to the sound section, I don’t see the microphone connected (none of the 4 tested ones are detected), and therefore, no application can detect the microphone, which is something I really needed.

When I use Linux Mint, everything works (the microphone is detected properly).
At the beginning, when I freshly installed openSUSE, the microphone was detected. Unfortunately, the microphone had noise, and I was looking for a setting that would turn it off.
In the sound settings, I tested various modes, and when I turned on a mode, the microphone disappeared. When I physically disconnected and reconnected the microphone, it appeared for 0.1 seconds and then disappeared.
The next day, I tested a few more microphones, and they worked (there was no noise at all :D).
However, the next day, none of the microphones were detected by the system. I’ve been looking and looking, and I can’t find how to fix it.

How can I make that when I go to the system settings and then to the sound settings, in addition to the speakers, the connected microphone also appears?

I apologize for my English, as it is not my native language.

Welcome to openSUSE Forums. You’ve described the issue you’re having clearly enough. Now we need to find out what the underlying cause of this is due to.

To start with could you please run the following commands and post the output here so that we can know a little more about the current working audio environment:

inxi -Aa
systemctl --user list-units | egrep -i "pulse|wire"
wpctl status

Additionally, I forgot to mention that when I watch/listen to something (but usually always and only then I can notice it), the video/audio lags strangely for 0.5 seconds. The track pauses, rewinds for a while, 0.1 seconds, and then goes back 10 times to 0.001 seconds, which gives a strange and quite unpleasant feeling. After 0.5 seconds, everything is fine again, but then the issue reoccurs every 10 to 30 minutes.
While this is a small problem compared to the lack of microphone detection, it is still related to the sound, so I thought it was worth mentioning.

Please copy/paste the output here as text. Use the ‘</>’ button (pre-formatted text) when posting this.

kak@zapaskak-desktop:~> inxi -Aa
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 1f:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 21:00.3
    chip-ID: 1022:1457 class-ID: 0403
  API: ALSA v: k6.8.6-1-default status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
kak@zapaskak-desktop:~> systemctl --user list-units | egrep -i "pulse|wire"
  sys-devices-pci0000:00-0000:00:01.1-0000:01:00.0-net-wlp1s0.device                                                              loaded active plugged   RTL8188EE Wireless Network Adapter
  sys-subsystem-net-devices-wlp1s0.device                                                                                         loaded active plugged   RTL8188EE Wireless Network Adapter
  pipewire-pulse.service                                                                                                          loaded active running   PipeWire PulseAudio
  pipewire.service                                                                                                                loaded active running   PipeWire Multimedia Service
  wireplumber.service                                                                                                             loaded active running   Multimedia Service Session Manager
  pipewire-pulse.socket                                                                                                           loaded active running   PipeWire PulseAudio
  pipewire.socket                                                                                                                 loaded active running   PipeWire Multimedia System Sockets
kak@zapaskak-desktop:~> wpctl status
PipeWire 'pipewire-0' [1.0.5, kak@zapaskak-desktop, cookie:3107827636]
 └─ Clients:
        32. xdg-desktop-portal                  [1.0.5, kak@zapaskak-desktop, pid:1907]
        33. WirePlumber                         [1.0.5, kak@zapaskak-desktop, pid:2283]
        41. WirePlumber [export]                [1.0.5, kak@zapaskak-desktop, pid:2283]
        60. pipewire                            [1.0.5, kak@zapaskak-desktop, pid:2638]
        61. Chromium input                      [1.0.5, kak@zapaskak-desktop, pid:2342]
        62. libcanberra                         [1.0.5, kak@zapaskak-desktop, pid:2105]
        63. plasmashell                         [1.0.5, kak@zapaskak-desktop, pid:2105]
        64. Plazma - PA                         [1.0.5, kak@zapaskak-desktop, pid:2105]
        65. WEBRTC VoiceEngine                  [1.0.5, kak@zapaskak-desktop, pid:152]
        66. WEBRTC VoiceEngine                  [1.0.5, kak@zapaskak-desktop, pid:152]
        67. Chromium input                      [1.0.5, kak@zapaskak-desktop, pid:204]
        74. Brave input                         [1.0.5, kak@zapaskak-desktop, pid:358]
        93. Brave                               [1.0.5, kak@zapaskak-desktop, pid:358]
        94. wpctl                               [1.0.5, kak@zapaskak-desktop, pid:5269]

Audio
 ├─ Devices:
 │      42. Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] [alsa]
 │      43. Family 17h (Models 00h-0fh) HD Audio Controller [alsa]
 │  
 ├─ Sinks:
 │      47. Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI 4) [vol: 0.40]
 │  *   48. Family 17h (Models 00h-0fh) HD Audio Controller Analogowe stereo [vol: 0.63]
 │  
 ├─ Sources:
 │  
 ├─ Filters:
 │  
 └─ Streams:
        68. Brave                                                       
             70. output_FR       > ALC892 Analog:playback_FR    [active]
             71. output_FL       > ALC892 Analog:playback_FL    [active]

Video
 ├─ Devices:
 │  
 ├─ Sinks:
 │  
 ├─ Sources:
 │  
 ├─ Filters:
 │  
 └─ Streams:

Settings
 └─ Default Configured Devices:
kak@zapaskak-desktop:~> 

Ok, my recommendation is to check the current profile. Since you have pipewire-pulse active, you can fire up pavucontrol, (install the package if not already present), and check the ‘Configuration’ tab for the active profile. Change as required, and check that the mic is not muted and correct levels set.

I didn’t fully understand, but I also want to point out that it’s not like a program like Discord doesn’t pick up sounds when I set the microphone. In general, I can’t select the microphone, as the whole computer thinks that I haven’t connected the microphone.

I ran pipewire-pulse and it doesn’t detect any microphone

some programs were recommended to me such as pipewire-pulse. However, I don’t really know how to use them, and I won’t feel sorry about removing them if that’s necessary to fix such issues.

my system not see eny microphons :frowning:

No, you don’t run pipewire-pulse. It is a systemd service that starts a daemon that is already active in your OS. I asked you to run ‘pavucontrol’. (You may need to install the ‘pavucontrol’ package first.)

i open pavucontrol end open configur
image

I played with the settings in this program and the microphone is detected :DDDD

thank you for your help from the bottom of my heart <3

So, resolved now right?

yes but can you tell me what happened?
why when I selected options in this program, suddenly the whole system saw the microphone again?

The wrong profile was selected. I can’t really comment further about the underlying cause though.

FWIW, a similar discussion here…
https://bbs.archlinux.org/viewtopic.php?id=291807

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.