The screen locker is broken and unlocking is not possible anymore

Came home, tried to resume my PC and this showed up

I offcourse tried the command “loginctl unlock-sessions” both as my user and as root but to no avail. It said “too few arguments”

Had to reboot the PC

I have had that happen. Using “loginctl unlock-sessions” did work for me (I had to run that as root).

Another option would be: CTRL-ALT-BACKSPACE (twice). That should crash the X-session and allow you to login to it again.

I normally turn off the screen locker (computer is in a sufficiently secure location). And then this never happens.

Ok it seems that the culprit was /tmp being full.

After rebooting Yast, Chromium, etc did not launch, so I looked at what the terminal gives and my / partition was full. Cleared some space and now apps launch but I cannot reproduce the “broken screen locker”. I’m over 70% sure that was the issue.

P.S: Is there a way to set /tmp to clear at reboot? I noticed that folder is taking a lot of space and contain very old files, even iso files I wrote 3 month ago on discs.

Look in “/etc/tmpfiles.d”. If the file “tmp.conf” does not exist there, then copy it from “/usr/lib/tmpfiles.d”. Then edit it. There’s actually a man page for “tmpfiles.d”.

Drop a bash script into ~/.config/plasma-workspace/shutdown/).
I use this method on a 13.2 “KDE4 Plasma” machine but, haven’t yet found a need to do the same sort of thing with Leap 42.1 and “KDE Plasma 5”.

I was wondering why “passwd -e” does not force the user to change the password via tty or display manager. “chage -d 0 user” did not work either. Heck!

I have reproduced the error about of screen-locker, it may not be your case:

First, lock the screen from your active session, then try to start with a new user, in my case, an expiration notice was shown and I threw out tty or GUI login.

Second, I can not unlock my session from the new session screen (any idea?) so I start a new session.

Third, try to block and unblock session again, voilà!

You must unlock the session with “loginctl unlock-sessions” or start over with “loginctl terminate-session ID”.