The road to systemd for openSUSE 12.1

Hi all,
systemd is coming for next openSUSE (12.1) scheduled next fall… read more here;

[opensuse-factory] The road to systemd for openSUSE 12.1](

Hash: SHA1

Gotta admit… some good stuff to be read in there and some really neat
features. I, for one, welcome our new Systemd overlords. :slight_smile:

Good luck.

On 06/10/2011 11:36 AM, malcolmlewis wrote:
> Hi all,
> systemd is coming for next openSUSE (12.1) scheduled next fall… read
> more here;
> ‘[opensuse-factory] The road to systemd for openSUSE 12.1’
> (
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


This looks very interesting. Thanks for the link malcolmlewis

Thanks malcomlewis. I also noted that on [opensuse-project] in addition to [opensuse-factory] and I suspect it could be on a few other mailing lists as well. Its quite significant.

It makes me wonder if this increases the risk when testing an openSUSE-12.1 milestone release on a PC with multiple partitions. For example, on my Sandbox PC I have 2 hard drives, with the 1st hard drive having 3 boot partitions: freedos, openSUSE-11.4, and tumbleweed-11.4.

The second hard drive is carved up but nothing inside the partitions. I was thinking of putting 12.1 milestones on this PC for testing, but now I’m thinking twice , as I want to understand the implications of systemd and the risk to breaking my nominal grub boot.

Here are my partitions:

Disk /dev/sda: 320.1 GB, 320072933376 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63     1044224      522081    6  FAT16
/dev/sda2   *     1044225    52243379    25599577+  83  Linux
/dev/sda3        52243380    54283634     1020127+  82  Linux swap / Solaris
/dev/sda4        54283635   625137344   285426855    5  Extended
/dev/sda5        54283698   515076029   230396166   83  Linux
/dev/sda6       515076093   566275184    25599546   83  Linux
/dev/sda7       566275248   625137344    29431048+  83  Linux

Disk /dev/sdb: 163.9 GB, 163928604672 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048    52436991    26217472   83  Linux
/dev/sdb2        52436992   104871935    26217472   83  Linux
/dev/sdb3       104871936   110446591     2787328   82  Linux swap / Solaris
/dev/sdb4       110446592   320172031   104862720    f  W95 Ext'd (LBA)
/dev/sdb5       110448640   215302143    52426752   83  Linux
/dev/sdb6       215304192   320143359    52419584   83  Linux

Where sda1 is freedos, sda2 is openSUSE-11.4, and sda6 is tumbleweed-11.4. Other Linux partitions on sda are /home partitions.

So I am now tempted to put 12.1 in either sdb1 or sdb2 (with the corresponding /home in sdb5 or sdb6). But will systemd impact my MBR and my current boot ? Clearly, I will need to back up my MBR before doing anything.

I don’t think it interacts with the bootloader at all. It springs into action after the kernel and initrd are loaded. It takes the place of init.

I hope so. I noted this quote:

phase 1: detecting current issues with systemd. Install systemd package and “manually” boot with it, by adding “init=/bin/systemd” at you kernel boot command line. In this setup, we want to find ALL the issues caused by switching to systemd, so please, check systemd on Factory status page[2] and follow the instructions there to fill bug reports. We also want to ensure there is no regression, when using legacy sysvinit initscripts with systemd as boot manager

I’m trying to wrap my head around this (and even though its past 12noon I’m still one-half asleep).

So initially there is a boot code to test this. But later presumably that line needs to be put in grub’s menu.lst … which may mean I need to be careful with any custom grub edits.

What happens is that the initrd knows what process to make the process id 1, the parent of all processes. Normally this is is /sbin/init. However it can be overridden from the boot parameters for rescue or testing purposes. Presumably when systemd is stable, /sbin/init will be an alias for it.

That description of systemd as boot manger is a little bit misleading, as people like you have inferred some connection with the bootloader. Initialisation manager is probably closer to it.

init - Wikipedia, the free encyclopedia

Has any tried booting with the boot code:


The need to test that was noted above.

I tried this on my 32-bit openSUSE-12.1 milestone1 LXDE install. I can’t notice any difference.

What should I test ? What should I look out for ?

Should I test both with and with out it and compare the two different dmesg ? Look for new errors ?

I have not a clue ! :frowning:

Reference systemd, there is an interesting thread on the opensuse-factory mailing list. [opensuse-factory] Tumbleweed systemd does not allow my computer to boot](

Apparently systemd appears to some not to support a separate /usr partition (without other changes being done to GNU/Linux). The explanation are given here : - Software/systemd/separate-usr-is-broken

On 2011-06-19 20:36, oldcpu wrote:
> Apparently systemd appears to some not to support a separate /usr
> partition (without other changes being done to GNU/Linux). The

Yes, that alone would impede me from using systemd at all. Not for factory,
but for installing 11.2 as stable when the time comes.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Actually the correct reading of that article is that systemd is the messenger of bad news when other software breaks with a separate /usr and the system is broken already with or without systemd.

More on systemd, which I copied from another post of mine on a different thread.

When booting with systemd to run level 3 (pressing < esc > to see text ) I also noted systemd would write half way down the page (with far less screen posts than the nominal boot), and it would sit at “systemd-fsck” of my last partition for a while, and then it would jump to the top of the page, not clear anything, and provide me the login prompt in the middle of many characters written before. That’s clearly a bug as one could miss the login given the other text that was not cleared. Am I the only one to see this ?

I noted 12.1 with systemd booted about 10% faster than without systemd on my ancient sandbox PC (athlon-1100 w/2GB RAM, and a nVidia FX5200). Wired internet work, as did sound. My wireless printer worked (I printed via wired to my router and then via wireless to the printer).

I plugged in a USB stick, and while copying a large file from my hard drive to the USB stick I played a music video and surfed on the web. The video played back (with music) flawless, but the USB copy was slow as was the net surf. I double checked without systemd and noted same behavior. I also note on this OLD pc that on openSUSE-11.3 I obtained far worse behavour on video playback (it would stutter when I did things in other apps). So this was a 12.1 improvement over 11.3 and NOT a systemd specific behaviour improvement.

I then tried wireless on both 12.1 original and systemd.

Both 12.1 original and 12.1 systemd work with my wireless, BUT 12.1 systemd has problems with “user controlled with NetworkManager” in LXDE. When I have that option chosen, 12.1 systemd takes ‘5 minutes’ EXTRA to boot, which is an unpleasant additional delay added to the boot time. If I then in YaST switch to “Traditional method with ifup”, and test the boot time, then systemd has the 10% boot speed advantage over the nominal 12.1 boot without systemd.

So it appears systemd on this LXDE PC does NOT like wireless with “user controlled with NetworkManager” setting in YaST with an in LXDE desktop. Network details of this test PC:

00:08.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139]
    Kernel driver in use: 8139too
00:0a.0 Ethernet controller [0200]: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter [168c:0013] (rev 01)
    Subsystem: D-Link System Inc AirPlus DWL-G520 Wireless PCI Adapter (rev. B) [1186:3a13]
    Kernel driver in use: ath5k

On 2011-06-20 04:06, ken yap wrote:
> Actually the correct reading of that article is that systemd is the
> messenger of bad news when other software breaks with a separate /usr
> and the system is broken already with or without systemd.

Worse: they do not want to repair it. :-//

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Yes, but the they is not the systemd project.

init(8) is the default ancestor process, it reaps zombies periodically for instance (processes which exited but parents exitted without readomg their return statuses, which would clog up the system if no action was taken).

exec init 3 will change run level from graphical to text with networking, calling Sys V init scripts to kill (signal to exit) unwanted processes and transition the system from 1 state to the other in orderly fashion.

By the way on a real Sys V rel 2 box (even dual CPU) it used to take about 5 minutes to go from Multi-User with networking to Multi-User on console, so a heavy price was paid in old days for the management flexibility; BSD based systems using simple /etc/rc & /etc/rc.local scripts booted a hell of a lot faster, but you had to know (or write scripts) what to kill yourself when shutting down things like Relational DBMS’s.

LWN ( has covered systemd quite well, with input from Lennart Poettering (previous best known for breaking sound with Pulse Audio) commenting on issues like seperate /usr being unsupported (due to decisions made on udev IIRC). Really annoying that desktop developers, wind up out of touch with reasons for old sysadmin practices for the most robust systems. Seperating / & /tmp, /var & /usr makes a lot of sense, though perhaps stripping out /tmp & /var is most of the “win”, though as pointed out it’s not Lennart’s bug he’s really raising awareness of mistakes(?) made by other developers.

On 2011-06-23 03:06, ken yap wrote:
> Yes, but the they is not the systemd project.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

If you have got too much time on your hands, there’s someone popped onto Factory list to have a trollish rant - [opensuse-factory] I’m a user, and I don’t want systemd](

What is it about systemd, that’s got ppl so wound up? I don’t like the desktop jockeys making /usr have to be in root filesystem, but it’s not too hard to :

cd /usr && mkdir usr_real && mv * usr_real && cd / && cp -ax * /usr && mv usr{,.mount} && cd /usr && mv usr_real usr && mv usr/lost+found .

Then edit /etc/fstab and if you were not clever enough to use seperate /boot, you might need to reinstall GRUB. You can fix up disk label with “tune2fs -L RootAndUsr”

Interesting article at : First Avahi then PulseAudio and now systemd with coverage by LWN at Interview with Lennart Poettering ( with some added comments on Audio. : Except Ubuntu it seems that systemd will be the future init system for most of the major distributions. Did you expect this quick success ?

Lennart : We quickly knew we had created something really good, but it was much easier to push this through than we anticipated. It took as one year from announcement to get it shipped in f15, and afaics it has been quite sucessful in it. In many ways it was like running along a long corridor and kicking in open doors.

Insert quote here about an idea whose time has come.

Time to require growing a beard, before touching system software!! :slight_smile: >:)

Solution to all the systemd nightmares and worries - Ken Thompson & Dennis Ritchie introduce Unix
Small & simple, seperate / & /usr and none of that nasty udev stuff or hooks for bluetooth or worries about dbus & policy kit!

Doesn’t Lennart look worringly like a young William Gates III - Lennart Poettering image - Google Search>:)