the new one (12,1): devices not found!

I am going to install openSUSE 12,1 on my machine.
so, like I usually do, I burn my USB key and launch the installation, but during it loads, he blocks telling it doesn’t find any devices (cd, dvd or others).
is it a bug or a problem of my pc?

is there a way to fix it?

thank you, have a good day! :wink:

did you check the burned media

I don’t think that works from a usb. When I tried it, it said that it could not find the CD or DVD to check.

Question for OP: When booting your USB, which I assume comes from the DVD, did you hit F4 to specify that the sources are on hard disk (the USB is treated as a hard disk). Or are you having problems before you see the boot splash screen for that USB boot?

Hi Alberto, hi nrickert,

I think the idea of caf4926 to first check the installation source/medium is absolutely good!

Alberto, did you work wih a .iso-image that you downloaded ?

In that case:

If you already have an older version of openSUSE (or another Linux distribution) running,
and if you still have the .iso-image,
than the quickest first check would be to open a terminal/console in the
directory with the .iso-image and enter

md5sum <filename>

where <filename> is the name of your .iso-image
(like openSUSE-12.1-DVD-i586.iso, for instance).

If it is a DVD image it may take a bit until the md5 checksum is calculated
and is output in the terminal/console window.

The correct values for the md5 checksums can then be found in
Index of /distribution/12.1/iso
in the files that end with .md5, which like the .iso-images should be downloaded from a mirror
(see links under ‘Details’ on that page for a link to a mirror to download from).

Good luck

thank you for your answers! :wink:

so nrickert, I changed my BIOS options to allow USB stick starts as first device.
I didn’t press F4, should I press it?
and yes, I have your same problem: “I don’t think that works from a usb. When I tried it, it said that it could not find the CD or DVD to check.”
in that case I will burn the image on a disk :stuck_out_tongue:

caf4926, I haven’t the choice you told me: i have only live, installation, boot from hard disk and memory check, where can I find the image with that voice?

ehi Mike! no, I don’t have anymore old image of openSUSE 11,4.
I tried to upgrade it without any new image: but I am trying to do it with another pc.
I downloaded the .iso from official web-site, could I perform a checksum on this new .iso? I should perform it on a linux operative system.

greets by
Alberto rotfl!

It’s on the DVD when first inserted in the player. You’ll see the menu.
It can also be found in Yast. Look for “Media Check” in the Software section.

Yes, you should (unless you are booting to rescue mode). It wants to find the install sources on the DVD, and F4 tell it to instead look on a disk device. The USB stick counts as a disk device.

But there was no DVD inserted in the player. There was no DVD. The OP had “burned” the iso to a USB stick, which is not a DVD.

When I try that, and boot from the USB stick, yes there is a menu item for checking the media. However, if I select that menu item, it complains that there is no DVD or CD to check.

Personally, I do check the iso after download - I check the gpg signature. And I copy to USB using dd_rescue, which seems to be doing a fine job of checking whether the copying was correct. I could separately compare the USB with the iso afterward, but the checking by dd_rescue seems to make that superfluous.

I’m not sure why the “media check” is hard coded to check a DVD or CD. It seems to me that it should default to checking the boot device or root device. However, that still might not work for the DVD, since you have to modify the iso with the “isohybrid” command before writing to the DVD. It might work when the USB is made from the live iso, which can be written to the USB without modification.

Dear Alberto,

very good !

Of course!
That is exactly what I meant :slight_smile:
It is the new .iso-archive, that you downloaded, of which you should ensure that it intact !
In my last posting, when proposing to make use of
md5sum <filename>
from a terminal/console, I took ‘openSUSE-12.1-DVD-i586.iso’ as an example for an image, which is the
install DVD for opensuse for 12.1@32Bit, not 11.4.

You mean you have a Linux system running?
That would be perfect !
Because only in this case you can make use of

md5sum <filename>

on the command line, within the directory in which the .iso-image is.

Under windows this wouldn’t work.

As mentionned in my last posting you can then compare the md5-checksum you calculated
by that call with the md5-checksum given in the related .md5-file on
(or a mirror).
If they are identical, you can be sure that your download of the .iso-image is intact.

Good luck

yes, like nrickert said, I would boot operative system from a USB key and my purpose is to install it on my machine; maybe the problem is I downloaded live version and not the DVD image.

should I burn the USB with big DVD image that will check if there are any devices?
what dd_rescue is nrickert? I’ve never heard that. :open_mouth:

ratzi, probably is that: you believe I am using a DVD disk image, but I am not, I got only a live :wink:
I thought it was the same thing for install a distro.
I performed the checksum (I meant I have any linux distros right now) and its result is equal to original checksum.

my check: 69a09b4e53308fa6d76e84494a086cfa
original check: 69a09b4e53308fa6d76e84494a086cfa
image name: openSUSE-12.1-KDE-LiveCD-x86_64.iso

I suppose the new .iso is OKay lol!

That should do fine. But forget the advice I have about F4 - that was assuming that you had the DVD image. You don’t need that with the live image.

I have tried the live images, both 32 bit and 64 bit, for KDE live 12.1. Both boot up just fine. If this is your first time installing from a USB stick, then using the live image is the best choice. There is less to go wrong.

It’s a nice little linux program for block copying. It does not normally come as part of the installed system, so I installed from the standard repos. You can do without it. I don’t know if there is a Windows equivalent.

That’s the correct md5sum for the live image. Your download looks good.

Installing from the live image works a bit differently from a DVD based install. With the DVD, there’s a software selection part of the install procedure. Using the live CD, there’s no software selection. You install exactly what is on the CD, no choices. Basically, the installer just copies from the CD, then sets up booting. It usually works very well, and is a quick install. But if you are not satisfied with the software selection, you will later have to go into Yast → Software management to install other stuff from the repos.

None of this explains why you are having problems. The live USB should just boot up into a running system. You can install from there, or you can select “Install” on the boot menu. Either way should work.

That wasn’t me!

Dear Alberto,

A new DVD-.iso-image in your situation will probably not be helpful!

The DVD-image is 4.x GB large and that will pose new problems
when it should be used on an USB stick (you call it USB key),
if you never formatted this USB stick using another file system
(like NTFS, or ext3, or …), and if this USB stick thus still has a FAT file system,
which still is the usual file system on the USB sticks when they are sold.

So just don’t do it for now, i.e. writing a DVD-image to your USB stick
(doing it later may be a different thing).

I have a few further questions:

(1) The .iso-image for which you verified the md5 checksum,
was it on a harddisk, or was it on the USB stick ?

(2) Does your laptop/notebook have a CD drive ?
In this case you could burn your live-CD-.iso-image

  • for which you verified the md5 checksum (and which thus is valid!) -
    to a CD (or ask a friend to do so),
    and you could try to install from that CD.
    Try that if your laptop/notebook has a drive that can read CDs!!

(3) When you tried to boot from the USB stick (or USB key, as you call it),
has there been any bootable system (like e.g. windows or some other linux) on your hard disk,
or hasn’t there been no system at all?
If not, that could be one explanation for the error messages you’ve got
when trying to boot from your USB stick.
Based on your postings I would say that there hasn’t been any bootable system,
but please respond anyway.

(4) When you ‘burned’ (your words) the .iso-image to the USB stick,
how exactly, or by which way, or by the use of which programs/apps, did you do it?

OKay, thank you nrickert!

I will answer to you, Mike.

First, excuse me if I used some inappropriate words like burn USB or others…

… then,

1- I checked my image from hard disk;
2- yes, it has a CD reader. I copied system into a key\stick 'cause it is faster and cheaper than CD and 'cause I should install openSUS3 only once;
3- my hard disk results so: 4-(5) partitions: 1st original informations, 2nd windows, 3rd old openSUSE and 4th openSUSE’s swap memory. (5th) really I don’t know where failsafe or emergency mode is saved.
4- it is universal USB installer, this is the link: Universal USB Installer – Easy as 1 2 3 | USB Pen Drive Linux

It is possible that the USB installer is the cause of your problems.

Normally, one has to tweak the iso before installing on a USB. However, the iso for the live versions of opensuse comes pre-tweaked, and perhaps that USB installer is getting confused by that. You might want to try the method suggested here:
SDB:Live USB stick - openSUSE
(it suggests using ImageWriter).

Dear Alberto,

No problem. If I would have had problems to understand you I would have asked more questions :slight_smile:

Fine. So as long as you don’t delete this image you will have a sound starting point for the installation.

On the other hand it then seems quite clear that the problems concern the USB stick.

Because of that I would suggust you as well to follow the description in
SDB:Live USB stick - openSUSE

I don’t know Universal USB Installer.

If you shouldn’t be successful either in following
SDB:Live USB stick - openSUSE ,
a further possibility would be that the USB stick that you use is damaged.

Hmm, only once.
On the one hand yes.
On the other hand there are situations in which it helps when you can boot from a live CD
e.g. to access your linux partitions when you have problems booting linux from your hard disk.

Think it over.
And if you should continue to have problems installing from the USB stick
then the CD can be a reliable alternative.
If you burn a CD, remember however to chose the slowest possible speed during burning,
in order that the CD is best readable.

Good luck !