the "Multimedia in One-Cick" dilemma

Hi all,
I just read the sticky and found out the install page redirects here, which is an official guide for Leap.

  1. I’m on Tumbleweed
  2. I alredy installed this (which I found by google): was it a mistake to install it?

I would prefer the suggested solution if:

  1. it fits even for tumbleweed systems
  2. it is less likely to break the system and more easy to maintain

Thanks in advance for the great help as usual! :slight_smile:

Unfortunately, the second link is down at the moment so I cannot look at it specifically, but it seems to be a 1-click installer.
If it is what I think it is, it should work with all supported openSUSE versions though, including Tumbleweed.

The first link applies to Tumbleweed as well (there are not really differences between 13.1, 13.2, Leap 42.1 or Tumbleweed in this regard), you’d need to adapt the URLs to the Tumbleweed repos though.

To check if you made a mistake, please post your repo list:

zypper lr -d

Personally I never used any of those guides or 1-click installs. In the end you just need to add the Packman repo (which you should even find in the “Community Repositories” list in YaST->Software Repositories, not sure if it has been added already for Tumbleweed though), preferably do a full switch (this is something the guides and 1-click installers neglect IIANM), and then install packages as you need/miss them.

That guide tells you some recommended things to install, but it might also install things that are unnecessary for you. (there’s never a 1-size-fits-all).

Installing Packman in Tumbleweed is covered here

I was actually wondering why over here( it says “For technical reasons codec 1-click installation is not currently available. In the meantime refer to”… that’s actually what made me think something could possibly be wrong (and hence not suggested anymore) with the 1-click installers.


before trying other way of installing the media codec (as nicely suggested by you, thanks) I’m still stuck to when I choose the 1-click installation.,
Yast2 is asking me about a library conflict. It says (I’m translating, hope it makes sense, the system is not set in english):
“PackageKit-gstreamer-plugin-1.0.11-1.1x86_64 installation will make obsolete opensuse-codecs-installer <= 10.3.1, provided by opensuse-codecs-installer-10.3.1-71.4.noarch”
And then offers two solutions:

  1. Uninstall PackageKit-gstreamer-plugin-1.0.11-1.1x86_64
  2. To not install opensuse-codecs-installer-10.3.1-71.4noarch

Thanks! =)

Well, “opensuse-codecs-installer” is not what you think it would be.
It’s old and obsolete AFAIK.
PackageKit-gstreamer-plugin (which you have installed) replaced it, which is a means to let the system automatically search and install missing gstreamer codecs/plugins.

So don’t try to install it.