The login screen cannot display

Last week, after install successful OpenSUSE 11.1 from the KDE4 LiveCD, I install the kde4-amarok-2.0 with yast2. The installation was fail and after that I cant login to desktop through the login screen. After the green boot screen finished loading, this message error box appeared:

“No greeter widget plugin loaded.”

After I click the “OK” button of the message box, the screen returned to the console login screen.
I must login with this then use startx to start the X.

I also cant shutdown, restart or lock my laptop. I can only logout to the console screen and then shutdown my laptop here.

Thanks for read and… Any ideas?

More infos:

  • I’m use HP6530s laptop

linux-ogso:~ # uname -a
Linux linux-ogso #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

Boot failsafe and at the login prompt, login with your username and password, then
do this:

mv /home/*usernme/.kde4 .kde4old

(*username = replace with your username, and notice the period . )

when done reboot

see if that helps, it will create a totally new .kde4 folder

Thanks for reply. But there is no change. I still have to use startx to start KDE.

Post your


My English is not good, so perharps u haven’t understood me. This is my problem:

  • The login screen doesn’t appear, and there is a dialog with the content: “No greeter widget plugin loaded. Check the configuration” and an OK button.
  • When I click the OK button, I am brought back to the console login screen (lv3 login).
  • I can connect to the X server and start KDE with the command startx.
  • I cannot lock, shutdown or restart my laptop. When I click Lock button to lock my session, a dialog appears. And this is its content:

Will not lock the session, as unlocking would be impossible:
No appropriate greeter plugin confifured.

Anyway, this is my menu.lst:

cat /boot/grub/menu.lst

Modified by YaST2. Last modification on Fri Dec 19 00:13:42 ICT 2008

default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1
root (hd0,1)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-FUJITSU_MHZ2120BH_G2_K615T872G0L1-part2 resume=/dev/sda4 splash=silent showopts vga=0x317
initrd /boot/initrd-

###Don’t change this comment - YaST2 identifier: Original name: windows 1###
title Win Vista
rootnoverify (hd0,0)
chainloader +1

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.1
root (hd0,1)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-FUJITSU_MHZ2120BH_G2_K615T872G0L1-part2 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
initrd /boot/initrd-

Hi thangola

This is a strange one. I found a similar thread here.

As you can see they were missing kde4-kdm package. Check with

rpm -qa |grep kde4-kdm

For reference, I get

rpm -qa |grep kde4-kdm

Hopefully its something as simple as this. :slight_smile:

Thanks for reply, deano_ferrari ^^.
It seems this is my problem. When I check my packages:

rpm -qa |grep kde4-kdm

I don’t have a package kde4-kdm-branding-upstream installed. When I choose to install this package with yast, there is a conflict:

kde4-kdm-branding-openSUSE-11.1-66.4.i586 conflicts with namespace:otherproviders(kde4-kdm-branding) provided by kde4-kdm-branding-upstream-4.1.85-8.1.i586

What should I do now?

Login to a CLI as user
go su

then do

zypper in kde4-kdm-branding

(I think)

Zypper/Usage/11.1 - openSUSE

you might just try
zypper up

If you have further problems, we may also need to see list of repos you have enabled. To get this info:

zypper lr

The result (^o^)/

"kde4-kdm-branding-openSUSE" providing "kde4-kdm-branding" is already installed... Nothing to do

This is my repo list. I hope that it can help.

# | Alias                     | Name                      | Enabled | Refresh
1 | GNOME:Factory             | GNOME:Factory             | Yes     | Yes
2 | KDE:KDE4:Community        | KDE:KDE4:Community        | Yes     | Yes
3 | KDE:KDE4:UNSTABLE:Desktop | KDE:KDE4:UNSTABLE:Desktop | Yes     | Yes
4 | openSUSE:11.1             | openSUSE:11.1             | No      | Yes
5 | repo-debug                | openSUSE-11.1-Debug       | Yes     | Yes
6 | repo-non-oss              | openSUSE-11.1-Non-Oss     | Yes     | No
7 | repo-oss                  | openSUSE-11.1-Oss         | Yes     | No
8 | repo-source               | openSUSE-11.1-Source      | Yes     | Yes
9 | repo-update               | openSUSE-11.1-Update      | Yes     | No

login to CLI

go su

zypper refresh

zypper dup

After doing these commands, there is still no change. What should I do now?

# rpm -qa |grep kde4-kdm
# zypper in kde4-kdm-branding
"kde4-kdm-branding-openSUSE" providing "kde4-kdm-branding" is already installed... Nothing to do


zypper ref
zypper up -t package

See how that goes…

I note you have KDE4 unstable repo enabled. This may introduce risks to working desktop.

@caf4926: Can you take a look at his repo list? What KDE4 repos do you recommend?

If using the Unstable 4.2 beta the repos are:

Index of /repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_11.1

Index of /repositories/KDE:/KDE4:/UNSTABLE:/Extra-Apps/openSUSE_11.1

Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_UNSTABLE_Desktop

Index of /repositories/KDE:/Qt/openSUSE_11.1

I would question the necessity of the these:

I just wonder why Packman is not there:
Index of /pub/linux/misc/packman/suse/11.1

And even VLC, although I would expect it to be disabled.
Index of /pub/vlc/SuSE/11.1/