The Internet is closed....


I’m running a Sony Vaio Laptop with Tumbleweed for about one year. For the network connection I use the KDE network manager in the toolbar. Suddenly, I cannot reach the internet anymore (e.g. by opening firefox or fetchmail).

The strange thing is, I am still in the internal network, i.e. I can exchange files via Samba with my Windows laptop. The Windows laptop can reach the internet fine, by the way.

I ran the following commands which I found in another thread here in the forum:

ip -s link
ip a
ip r
grep -v -e ‘^#’  /etc/resolv.conf
ping -c 4
ping -c 4

The output of the ip commands looks “normal” to me. The /etc/resolv.conf looks like this:

# Generated by NetworkManager
search home
nameserver 2a02:810d:1980:5028:5e35:3bff:feff:473

The ping commands give no reply from or but full reply from

Above, I said “suddenly” I have no internet, but there is one thing I changed in the Network Manager: Usually, I use the cable connection to my router but once I tried to connect to my router via WLAN. This took many tries in order to convince the Network Manager to do this without using the password safe which I don’t have the password of. The description of the check boxes seems not right nor logical to me. Finally, I managed the WLAN connection but had no internet. Since then, I tried at different locations with different WLAN routers and also my home router via cable but I only ever get the connection to the internal network, never to the internet. To make things even more complicated I have a new home router now and cannot test on the old one anymore…

Since you say you have a new Internet router,
I’m going to assume that old settings aren’t likely used anymore.
I’m also going to assume that your home router is typically very simple, without the additional configurations that might be found in “better” equipment which you might find in business systems.

It’s progress if you say you can still access resources within your LAN, it is an indication that your machine is configured properly with some basic network settings.

Your next steps should be to test your network connectivity to your Default Gateway and then again beyond to an address on the Internet.
You’ll want to test first by pinging IP addresses to test basic connectivity, then again using names to test name resolution.

In home networks, generally the Default Gateway is the same machine and address as the DNS nameserver, so you should ping, not


If that works, then you should ping something on the Internet, a popular choice is a Google DNS server


If each test has been successful up to now, then you have established that your basic network connectivity to the Internet works fine, so now you can turn your attention to DNS resolution

You’ve already tested your connectivity to your LAN DNS, so you might test pinging any address on the Internet by name, take your pick. The following tests You can also try opening in a web browser, but know that there is one test you can’t do which is “” in a chrome or chromium browser because in that one case a page on your local machine is rendered, and does not reach out to the Internet


If all of the above succeeds except for the last, then your next step should be to invoke nslookup tests, post if you need help at that point and I can describe how to do that.


It is much, much better to post those commands and their output. So everybody can decide fir her/himself if the output looks normal. Now we have almost nothing.
I assume one of the things you hope people can do for you here on the forums is point to things you did not notice because other people having a fresh look can make a difference.

A couple of things:
Not using kWallet ( the password manager ) stores the passwords in the config files ( a no go for me ). I strongly suggest you use it.
Could you remove the current config and readd it using DHCP
Could you check if things work when using wicked instead of Networkmanager? ( Use YaST )
How do you update your TW install? FYI only ‘zypper dup’ is the way to do so.
Did you, after connecting the new router, reset your modem?

Thanks for the explanations. Just to clarify: I now have a new router incl. DSL modem but I couldn’t connect to the internet with my old router (incl. DSL modem) either for the last couple of weeks (before I had to sent it back). Neither via WLAN nor by cable. And also in some other WLAN’s of friends where I used to connect in the past, I can’t connect either, now.

Concerning the ping commands, I get no reply from nor but full reply from



ping: Temporärer Fehler bei der Namensauflösung

i.e. temporary error during name resolution.

If ping is a connection to the internet as you say, tsu2, then it seems to me, the problem is really with the name server configuration (which I never changed, as far as I know).

To the removing of the config:

Could you remove the current config and readd it using DHCP

Do you mean by deleting the old file and rebooting the laptop or the router?

Thanks for your help!

By the way, according to advice from this forum, I only update manually (which contradicts the whole idea of the rolling release a bit, but well). I have to admit, I only do it every few weeks because it is always a big problem and never really runs through (I never know what to answer to all the questions the updater asks me and if I say “no” somewhere it keeps asking me the same questions in a kind of endless loop until I finally say “yes” - against my feelings).

And here the output of all the ip commands, as requested (it is a little complicated to get it here in the forum, because the linux computer is not on the internet now…):

ip -s link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    RX: bytes  packets  errors  dropped overrun mcast   
    3416       38       0       0       0       0       
    TX: bytes  packets  errors  dropped carrier collsns 
    3416       38       0       0       0       0       
2: enp14s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 54:53:ed:2f:fb:39 brd ff:ff:ff:ff:ff:ff
    RX: bytes  packets  errors  dropped overrun mcast   
    68196182   142055   0       2       0       1742    
    TX: bytes  packets  errors  dropped carrier collsns 
    39795370   140389   0       0       0       0       
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DORMANT group default qlen 1000
    link/ether 1a:e3:63:6f:e4:12 brd ff:ff:ff:ff:ff:ff
    RX: bytes  packets  errors  dropped overrun mcast   
    20470930   33195    0       0       0       0       
    TX: bytes  packets  errors  dropped carrier collsns 
    16148813   29985    0       0       0       0       

ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp14s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 54:53:ed:2f:fb:39 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic enp14s0
       valid_lft 863630sec preferred_lft 863630sec
    inet6 fe80::b135:c21d:4fc5:9e24/64 scope link 
       valid_lft forever preferred_lft forever
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 2e:35:d6:59:33:2b brd ff:ff:ff:ff:ff:ff

ip r

default via dev enp14s0 proto static metric 100 dev enp14s0 proto kernel scope link src metric 100 

Then better ask here. IMHO it is not a good idea to answer those questions randomly with yes or no when you do not understand why. Asking here may increase your knowledge and decrease your problems.

I understand it is not very easy having not being able to use the forums on the same machine. But OTOH when we do no know anything, it is very difficult to help.

From your information it seems that is now your router. Thus try to ping that one (I assume that works because you say you can ping It is a bit unusual address though. An unusual type of router?

But it seems you have a DNS problem. And that is not so strange as you say that you have in your /etc/resolv.conf


which is not your router anymore. Try replacing this with the new address.

BTW this does not explain why this is not set correctly using DHCP.

If you’re using DHCP, try this:

su -c 'rm /etc/resolv.conf'
su -c 'rcnetwork restart'

That should recreate the file. If your router is configured to use google’s DNS’s, these should show up.

Agree with the comments immediately above.

Your DG and DNS addresses should both likely be

You can ping that address if you wish and should return results successfully.

You should also likely see that address listed if you inspect your resolv.conf file with the following command

cat /etc/resolv.conf

You should be able to delete the file with the following command and restart your networking service which should re-create the file correctly with the following command

sudo rm /etc/resolv.conf && systemctl restart network.service


Thank you! That worked!

I used

su -c 'rm /etc/resolv.conf'
su -c 'rcnetwork restart'

and I gather, the other two suggestions yield pretty much the same result.So thanks to all of you!

My router is a standard thing sent to me by the telephone company, by the way - or so I thought. It’s brand new, of course.

If I understand you correctly, the resolv.conf is recreated new, every time I connect to a new or different WLAN network. So, how could it happen that the resolv.conf was wrong and wasn’t recreated correctly when rebooting/connecting using the network manager? I hope, I don’t have to delete it every time I take my laptop to another network place with a different router configuration?

That with /etc/resolv.conf is a bit complicated. It could be that it is changed manualy to force a certain resolver configuration. When Network Manager gets the idea that this is the case it will not overwrite it with it’s own configuration. The originaly installed configuration tries to explian this with:

# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
### Please remove (at least) this line when you modify the file!

So specially when the last line isn’t there, NM (or in my wicked case netconfig) will not change the file.

While we can no more reconstruct while your file was seen as “manualy changed”, this did not matter as long as your router was still having the same IP address (as router). The new router has a different one, but no change was done. Removing the file forced it to be created anew.

BTW, next time try to be a bit more precise in reporting your problem. “The Internet is closed” is a bit exaggerated (all the newspapers would report this when it would be the case, well, mabe not, without Internet most newspapers would stop also I guess)). To begin with you used it yourself working on the forums.
And even saying that you could not reach the Internet from that particular system is not true because you could ping, which is on the Internet and you thus could reach systems on the Internet.