The forum search engine does not work

When you put any search term, it sends you to the advanced search, but it does not show you any results:|

You may get better results on Google with your search items

Hmm, here it works like a charm. Entering “forum search work” brings up this thread and a lot of other with the search terms highlighted.

I’m on FF93.0
KDE-Plasma-Version: 5.18.6
KDE-Frameworks-Version: 5.71.0
Qt-Version: 5.12.7
openSUSE 15.2

What’s your system? Maybe blocked cookies or other blockers hindering the search?

I have been experiencing this issue as well. No matter what I type into the search, I just get an advanced search menu without any results to show. I even tried “forum search work” like a user above me did and I didn’t get any results there. I cannot use the search at all

I typically go to the “Advanced Search” , and under that be certain to select the “Search Single Content Type”.

When I do that, the search works very good for me.

I’ve found the “problem” after testing this out. There’s a required random question for the search feature and it’s hard to see/notice at first because it’s the same size and colors as the other text boxes around it. Why is this required just to search through the forums? Even to use the basic search? That’s really perplexing to me. At least make it stand out so we know it’s necessary to use the search

Now you say so, there must be a similar thread here. Where you really logged in in the forums then, because I assume that anti-robot question should only work for those that are not logged in.

I was definitely logged in last time I tried and it was still asking the random question. If it’s only supposed to be there for guests then it’s not functioning that way for me apparently.

It could be you need a minimal amount of posts.

In any case, it works for most, but not very well for many. The way I suggested earlier might give better results.

It still works here without any issues, now on FF94 and even with FF on my mobile - both logged in. Then I tried safari just for the experience. I have switched off any java, cookies possible and did NOT login. Only then I have also seen that random question. After answering 101 plus 50 it even worked there. I think it is very likely some local settings / blockers whatever.