The following 4 package updates will NOT be installed:

hi, getting this message from zypper update:

Loading repository data…
Reading installed packages…

The following 4 package updates will NOT be installed:
google-compute-engine-oslogin growpart growpart-rootgrow python3-gcemetadata

Nothing to do.

Likely you have enabled multiple repositories from which those packages can be installed and a new version is available but from a different “vendor” and the updater doesn’t switch vendor by default.
Open YaST Software and see in the “Versions” tab for the package of interest what choices you have and whether you really want the “higher” version.

seems yes, you are right, first time when installed it was leap 15.1 on cloud, 15.2 not available yet, so i installed 15.1 and then upgraded to 15.2, i guess this updates not available for 15.2

Taking “google-compute-engine-oslogin” as an example:

[INDENT=3]<https://download.opensuse.org/update/leap/15.2/oss/x86_64/google-compute-engine-oslogin-20190801-lp152.5.4.1.x86_64.rpm&gt;[/INDENT]
AFAICS, the packages are in the Leap 15.2 OSS update repository …

thanx, very helpful