The eye candy side effects

Hi all :wink:

I’m wondering about the eye candy side effects, i’m using kde 4 and using kwin but i have some blinking effects.
I’m using a nvidia geforce 7900 gs and last nvidia driver (177.80 for Linux x86/x86-64 released - nV News Forums )

But i still have my menus blinking, not all the time, but it does blink enough so that i won’t tell my friends (newbies in linux) to use kde 4 / kwin .

So is it linked with the driver not able to render all the effects ?
Or is it the gui that’s not kwin optimized yet ?

But most of all : When is it supposed to be better ?

Thanks :wink:

From Projects/KWin/4.0-release-notes - KDE TechBase

Tip: Performance/smoothness with nVidia cards: Smoothness of KWin rendering can be improved by setting the env.variable KWIN_NVIDIA_HACK to 1 (e.g. append ‘export KWIN_NVIDIA_HACK=1’ to your ~/.profile file). This sets ‘__GL_YIELD=NOTHING’ for KWin, letting KWin use more CPU time for OpenGL operations, however at the expense of affecting performance of other applications. This option is enabled by default since KDE4.0.3, as the performance impact seems to be non-significant. See section ‘OPENGL YIELD BEHAVIOR’ in README.txt for nVidia cards for details.

Tip: In some cases, overall smoothness may be increased by turning off direct rendering in advanced options in the Desktop Effects configuration module (Alt+F3->Configure Window Behavior).

Tip: Changing the Texture filter in the Advanced Compositing Options to Nearest may improve performance considerably (at the cost of aliasing artifacts), especially on low-end graphics equipment.

For the first tip just open .profile file in your home directory and type “export KWIN_NVIDIA_HACK=1” without quotes.

are you using kde 4.0 or the latest kde 4.1.2??
if your using 4.0 the update to the 4.1.2
and see if that don’t fix your problems