The broadcom-wl wifi fails to connect on reboot - works after restarting network

On A Dell laptop with a Broadcom Wifi chip - I installed broadcom-wl (probably from packman)

Environment - OpenSUSE 15.0 Mate desktop, lightdm, iptables and network manager

After zypper installed the broadcom-wl and needed files I did a systemctl restart network and I used the setup to select the wifi and password and it connected.

On a reboot it pops up the the password box and it has the correct password but will not connect.

If I close the prompt for the password and as root I do the systemctl restart network it connect without any prompts.

I am considering adding a small script to sleep for 60 seconds and do the systemctl restart network on login ( I have already written a c program to do this and chmod 4755 as root to do this ).

Anyone know why this is happening or how to fix the issue.


zypper se -si broadcom kernel
zypper lr -d
uname -a

Please use Code-Tags, the small # in the Editor.

That is strange. How is your network connection defined? Try changing it to a system-connection via the NM connection editor > ‘Identity’ tab > ‘Make available to other users’.

**28.4.1 User and System Connections
NetworkManager knows two types of connections: user and system connections. User connections are connections that become available to NetworkManager when the first user logs in. Any required credentials are asked from the user and when the user logs out, the connections are disconnected and removed from NetworkManager. Connections that are defined as system connections can be shared by all users and are made available right after NetworkManager is started—before any users log in. In case of system connections, all credentials must be provided at the time the connection is created. Such system connections can be used to automatically connect to networks that require authorization. For information on how to configure user or system connections with NetworkManager, refer to Section 28.3, “Configuring Network Connections”.

That is already set.

I used a Realtek USB Wifi to set up the laptop as the Broadcom is not on the OpenSUSE 15 default install image - then I changed the mac address in the wifi definition that was the Realtek USB (wlan0) (that I used to run the add Packman repo and to do the zypper up) to the Broadcom (wlan1) mac address. This had always worked in the past - but this is a different Broadcom model than the HP laptops that this had worked on.

I have returned the laptop to the owner but I can have her allow me to teamviewer in to look at it. She is fine with my Rube Goldberg fix right now as all is working

You can try inspecting all the journal entries related to the network service, the following displays all such entries during your current boot

journalctl -u network.service -b

You can also try displaying all the errors during your current boot

journalctl -p err -b

I’d also suggest that you set up your wireless connections <not> as system connections if that’s what you’ve been doing.
When set up as a system connection, the connection is made very early in the boot process (before is achieved), if set up as individual User connections, the connection isn’t made until after your User logs in (ie after is achieved) so if there is a timing problem, that will likely be fixed.

You <shouldn’t> have problems with system connections but if they’re made when the Network Manager service is first started, that is practically after and might be as the network service itself is being started. It could result in a vert brief race condition where basic networking hasn’t yet completed its started before the wireless connection is made.


I suspect it is a race condition as this laptop has a slow 5400 rpm drive - all others have a fast SSD drive. It also has a very slow Centrino processor - the others have Core 2 Duo or better. I also see ntp spinning to connect and clamd with it spinning to connect on bootup - they both give up at about 45 seconds and the GUI appears at that time.