Text-to-speech app 'festival' not working after installation.

Hi all,

I am working on Gnome desktop. Had installed ‘espeak’ earlier but was not satisfied with the tone and pronunciation of the speech. After googling a bit came across ‘fetival’. Installed it and overcame the initial working issues with help from one of the earlier mails in our forum pages here. After linking all the *.scm files from ‘/usr/share/festival’ to ‘/usr/share/festival/lib’ (as explained in a closed thread on the subject in these forums) and copying the dirs ‘voices’ and ‘dicts’ from ‘/usr/share/festival’ to ‘/usr/share/festival/lib/’ the ‘festival’ is still not working. Error is as below:

rsp@dell-linux:~> festival --tts Desktop/reign*
Linux: can't open /dev/dsp

I am stuck at this stage. How to facilitate it to open ‘/dev/dsp’.

Would be grateful for help


(I use KDE, but there seems nothing KDE-ish to what follows.)

I got this error too after

zypper install festival

A quick search revealed this: https://wiki.archlinux.org/index.php/Festival#Usage_with_a_Sound_Server

As root, I did this (per your own suggestion):

mkdir /usr/share/festival/.lib
cd /usr/share/festival/.lib
ln -s ../* .
cd ..
mv .lib lib

Then, as ordinary user:

>> ~/.festivalrc

Open ~/.festivalrc with your favorite editor (I used mcedit) and add the next two lines:

(Parameter.set 'Audio_Method 'Audio_Command)
(Parameter.set 'Audio_Command "aplay -q -c 1 -t raw -f s16 -r $SR $FILE")

That should do it. Test with for example:

festival --tts <<<'Hello there.'

Kind regards,


Hi Leen,

Thanks a lot for your very useful solution. I do not get that error now. Obviously the ‘/dev/dsp’ can be opened by it.

But when I ask it to play a file from the home directory or Desktop, it makes some quirky sound and stops. Am I feeding it the file correctly?

rsp@dell-linux:~/Desktop> festival --tts reign-of-aurangzeb.odt

Shall be grateful for help.

Profound Regards,


It may note fully recognize odt files which would have embedded characters. Convert to pure text.

Hi Gogalthorp,

Thanks a lot for your quick response. Will do accordingly.

Profound Regards,