text mode after fglrx install (opensuse 13.2)

Hi all,

This morning my system failed to start in Graphic mode. I could use advanced options and go to the text console.

My graphic card is (lspci)
R7 250 Radeon HD 7700/7800

I read that specific drivers are available now:

https://forums.opensuse.org/showthread.php/502138-Anybody-managed-to-get-fglrx-on-13-2-yet/page3?highlight=Radeon+glx

So I followed the text and added the geeko.ioda.net, and used yast2. The choice they give in that repository is wide and I also added fglrx graphics.

After a reboot I fall in text mode because a glx driver is not found.

The output of Xorg.0.log is
http://paste.opensuse.org/88389601

It seems the problem is related to a glx module and the fglrx driver was loaded and the monitor is recognized.

How do I solve this?

Yes.
What repo did you add exactly?

zypper lr -d

If you added one for a different openSUSE version, it won’t work on 13.2.

Which fglrx packages do you have installed?

rpm -qa fglrx*

You might miss one, the fglrx driver has been splitted up into 5 packages for 13.2.

You might be able to get a graphical system by choosing “Recovery Mode” in the “Advanced Options” in the boot menu (should be the second entry).

My error. The output of rpm gives:


fglrx64_graphics_SUSE132-14.301.1001-99.x86_64
fglrx_xpic_SUSE132-14.301.1001-99.i586
fglrx_amdcccle_SUSE132-14.301.1001-99.i586
fglrx_core_SUSE132-14.301.1001-99.i586
fglrx64_core_SUSE132-14.301.1001-99.x86_64
fglrx_graphics_SUSE132-14.301.1001-99.i586
fglrx_opencl_SUSE132-14.301.1001-99.i586

So I mixed i586 and 64-bit and that doesn’t work. I installed all 64-bit and now it boots ok.

Thank you for your help.

Ok, thanks for the update.
:wink: