Texlive 2010

OpenSuse 11.1 ships with:
This is pdfTeX, Version 3.141592-1.40.3 (Web2C 7.5.6) (format=latex 2010.5.3)

I would like to install the following instead:
This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian) (format=latex 2010.9.28)

How should I proceed? Is there a one-click-install rpm or should I download the
whole LaTeX package “by hand”?

Thanks,
M. Natiello

First, have you tried checking YaST and the OBS to see if it is in the 11.1 repositories? If it isn’t, to avoid any dependency conflicts with programs that use TexLive, you may find that upgrading to 11.3 is the simplest way; you can then get TexLive 2009 directly from the openSUSE repositories.

Thanks, Wise Penguin.

I found texlive-2009 for suse 11.1 in the download service. Now I have it.
It is not the “debian” build, but Suse’s own. The problem is that it cannot deal
with resolving references in some contexts. Apparently, this depends on which
html package is built into pdfTex (that is the main difference between suse and
debian builds).

Have you heard of this problem? Is there a forum answer I could read? If not,
I can send you a sample input and output displaying the problem.
Thanks,

M. Natiello

As john_hudson said: it gonna be much easier when you upgrade to openSuse-11.3, then you get version exactly you want to:
This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/openSUSE)

I’m not clear what the problem that you are referring to is as I have never had any problems with pdftex in openSUSE.

Never mind. It turned out that the problem originated in a private package that
the editor of a journal requires for publication. Their package together with
texlive - suse install did not work properly. Anyway, I found a workaround.

I don’t know how to mark this thread as “solved”.

Yours,

M. N.