Testing suspend to ram

I’m playing with suspend to RAM in Opensuse Leap 15.3. I use to have my computer switched on all day, and as the electricity price is skyrocketing these days I wonder how much electricity will it use, so I have made some measures. My computer, switched on and without me doing something very demanding is using more or less 440mA, this is 96W. Switched off, as the computer do not switch off completely (I have wake on lan activated, I have not tested if it will use less power with WOL deactivated) it uses 22mA which is less than 5W. I did a suspend to ram to measure the power it use and I was surprised to see the there was no appreciable difference between consumption switched off and the consumption sleeping, so I decide to configure the computer to go to sleep after 10 minutes of inactivity.

The functioning is very satisfying in various aspects

  • Power consumption, as I said is less than 5W when I’m not using it
  • Noise. My computer is almost totally silent, I have no mechanical disk and only two fans: power supply fan and CPU fan, both of them very silent, so you almost can’t hear it in a normal day environment, but during the night you will hear, but in sleep the fans are switched off and the computer is exactly as switched off, the only difference I have seen is a front led of the case that is blinking.
  • Switch on/switch off time. With the nvme my computer boots and switch off very quickly, but sleep/resume takes about 2 seconds, so it’s awsome. Of course one of the advantages of sleep/resume is that whan you’re working with a lot of programs and documents opened accross some virtual desktops and you stop, you can let it as it is and continue with it the next day.

The problems which arise

  • First of all is about filesystems. I mount on boot some filesystems from a server, some of them NFS, other sshfs. Whe te computer go to sleep and then resume I have not noticed any problem with the nfs filesystems, but the sshfs connection is broken after 2h sleep, as has been talked about here. The solution is change some tcp parameters in the server although I think a better solution is use nfs instead of sshfs.
  • The second issue I am experiencing is related to graphics. Some times I sleep/resume, it works fine, but some times when resume, the text of the icons in the desktop is ilegible. Here is ok and here is bad… and more anoying, some times some of the text is ok and some is bad, like here. I haven’t found yet why is it happening. I will report here when i find it.
  • I have a wireless mouse with the dongle connected to a usb hub, and each time I sleep/resume the mouse is not working, I have to unplug/replug the dongle in order to have the mouse working. The keyboard is connected to the same hub, but is a wired keyboard and I have no problem with it, once sleeping I click any key and the computer resumes.

Of course you have to swith off/on “properly” when you want some upgrades to be applied, but for most work I will use it as my main way to use the PC once I have solved the icon’s text issue.

My hardware:

Motherboard: M4A89TD PRO USB3
CPU: AMD Phenom™ II X6 1055T
Graphics card: Asus GT720 ( NVIDIA Corporation GK208B [GeForce GT 720] )
Graphics drivers: nvidia-glG04-390.144
Hard disk: Crucial P2 CT1000P2SSD8 NVME connected to PCIe using an adapter MZHOU M.2 SSD M-Key NVM PCIe 3.0 x1
Using KDE Plasma [FONT=monospace]5.18.6

[/FONT]

Try to use G05 driver for Nvidia video card.
Try to update BIOS if available.
For me suspend-to-RAM (“Wait mode”?) works OK with Ryzen APU. With Leap 15.2 I had problems sometimes with waking from sleep (StRAM) - video driver hangs.
You may also use suspend to disk (“Sleep mode”?) (without secure boot?).

I tried G05 but it did not work with my card, so I guess I have to use G04 or nouveau.

I have other issue with the graphics card and vmware, I described it there… maybe they are related.

Gt 720 is supported: https://www.nvidia.com/Download/driverResults.aspx/184163/en-us

Version: 470.94
Release Date: 2021.12.13
Operating System: Linux 64-bit
Language: English (US)
File Size: 259.65 MB

Test it with fresh install - without installing nouveau drivers during OS install.

One funny thing about the icons texts. I have been trying to change the text in the configuration, or edit the icon and I havnt’t achieved to make the icon to recover its text, but if a move a icon, then the text returns and is ok.

Hi fperal and Happy New Year!
It’s really interesting. I have the same issue with the icons on my laptop when closing the lid. I never bothered but I assume it’s also suspending to RAM. Icon have grey/grizzled backgrounds/text, after moving it’s OK.
I have read this thread before but I wanted to be sure to reproduce: It happened on 15.2 (and I am quite sure with 15.1, as well). Just yesterday I upgraded it as last of four boxes to 15.3. And yes! It’s still happening. Nice coincidence: I can’t run G05, either, although I think it should be supported. G04 is fine. But it can’t be the culprit as I have an Optimus and it also happens with Intel GPU running. (BTW, first time upgrade with nvidia repo active and first time no trouble with the graphics on all boxes. On the laptop suse-prime switched to intel after the upgrade but had no trouble switching back to nvidia.)
To me it was never a real issue. I just mark one icon, then ctrl+a and move them all a few pixels. I wouldn’t bother about a bug report but if you wish to file one I’ll support it. Here’s some info:

**~ #** inxi -b 
**System:    Host:** mine **Kernel:** 5.3.18-59.37-default x86_64 **bits:** 64 **Console:** tty pts/7 **Distro:** openSUSE Leap 15.3  
**Machine:   Type:** Laptop **System:** Acer **product:** Aspire A517-51G **v:** V1.20 **serial:** NXGSXEV0228410AD223400  
           **Mobo:** KBL **model:** Dragonite_KL **v:** V1.20 **serial:** NXGSXEV0228410AD223400 **UEFI-[Legacy]:** Insyde **v:** 1.20  
           **date:** 06/04/2018  
**Battery:   ID-1:** BAT1 **charge:** 31.8 Wh (80.5%) **condition:** 39.5/48.9 Wh (80.8%)  
**CPU:       Info:** Quad Core Intel Core i7-8550U [MT MCP] **speed:** 800 MHz **min/max:** 400/1800 MHz  
**Graphics:  Device-1:** Intel UHD Graphics 620 **driver:** i915 **v:** kernel  
           **Device-2:** NVIDIA GP108M [GeForce MX150] **driver:** nvidia **v:** 390.144  
           **Device-3:** Quanta HD Webcam **type:** USB **driver:** uvcvideo  
           **Display:****server:** X.Org 1.20.3 **driver:****loaded:** modesetting,nvidia **resolution:** 1920x1080~60Hz  
           **OpenGL:****renderer:** GeForce MX150/PCIe/SSE2 **v:** 4.6.0 NVIDIA 390.144  
**Network:   Device-1:** Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet **driver:** r8169  
           **Device-2:** Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter **driver:** ath10k_pci  
**Drives:    Local Storage:****total:** 1.14 TiB **used:** 176.22 GiB (15.1%)  
**Info:      Processes:** 298 **Uptime:** 11h 43m **Memory:** 7.64 GiB **used:** 2.27 GiB (29.7%) **Shell:** Bash **inxi:** 3.3.04 

kinfocenter:

Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-59.37-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 7,6 GiB

Just let me know if you need other information for checking.

Wait! I’m not so sure anymore. I was quite sure I have just seen it with intel running. To be really sure I switched back to intel and now I couldn’t reproduce it anymore. Tried twice. And now three times even while having this post open. So it might be related to G04. At least there it reproduces each time. I’ll stay on intel for a while and check if the issue returns.

Oh well…! :
That seems rather erratic, now. FWIW:
Out of curiosity tried to install G05 (double checked MF150 should be supported).
prime-select nvidia fails - as with 15.2
Reinstalled G04 and switched to nvidia in tty0 before logging in to KDE.
Now - the glitch is not reproduced as easily anymore. Hmm…
There may be other factors that have an affect on the occurance. I’ll keep an eye on it. But for today it’s enough.:wink:

Hi fperal,

Not sure if you still pursue this. Here’s some update anyway:
I have been using intel since the last post - nothing. Yesterday I switched to nvidia. At first everything was fine. Just now, I lifted the lid, for maybe half a seconds all icon texts were readable and the the glitch reappeared. It’s G04 as G05 still won’t work.