Testing KDE4.5 beta 1

kde4-config -v
Qt: 4.6.2
KDE Development Platform: 4.4.80 (KDE 4.4.80 (KDE 4.5 Beta1)) “release 2”
kde4-config: 1.0

[QUOTE][/QUOTE]

Currently if you use the kdm4 login manager, the menu and session buttons are not working.

Enjoy!

Can I safely assume you are testing this on 11.3 M7?

Quite correct.
I’ll give more of a report by Friday AM

Thanks, that could be interesting.

I got a “could not start ksmserver” error. Now can’t enter kde:(

Try middle clicking on the buttons, worked for me :slight_smile:

I got the same error, has anyone got a fix for this?

Could not start ksmserver. Check installation. - openSUSE Forums

To update on my experience with kde4.5 beta1

I think with every numerical increase on versions the ‘System Settings’ has changed, not that that is a bad thing, but just as you figure out where one setting/customisation is, they move it. Well, you’ll not be disappointed this time round. They changed it again. But at least the TAB option has gone, putting all the main menu on one opening sceen.
http://thumbnails33.imagebam.com/8217/d354ee82163755.gif](http://www.imagebam.com/image/d354ee82163755)

Or you can now configure to this tree view:
http://thumbnails22.imagebam.com/8226/23709e82250585.gif](http://www.imagebam.com/image/23709e82250585)

On the whole, the experience is good in this beta release and so far, even though I am running this in 11.3 M7 as well, I could go as far as saying it’s fantastic.

Please though, if you are reading this and are new to Linux and or openSUSE. Don’t do what I am doing unless you know how to get yourself out of the crapper. Just because all things a wonderful for me, does not necessarily mean it will be for you.

What was I saying… Ah, Fantastic. Yes, really. I worked with it for 6 hrs yesterday and all my normal activity of web browsing, image editing, multi-media were fine. However sftp, ssh gave me some problems.
It was slow and the notification area was uninformative.
Here is a screen of a sftp transfer taking place:
http://thumbnails4.imagebam.com/8226/10411082251797.gif](http://www.imagebam.com/image/10411082251797)

The menu is messed up to, but I have to try a new .kde4 yet. But if I get to Applications it just shows a list of titles “Newly Installed”.

I’m working on the bug reports too.

Tested on 11.2, rolled back to KDE4 4.4.3, cause 4.5b1 kept on giving kded crashes. Bugreporter feature does not work either, causes another kded crash. I’ve kept the messages, found an already entered bug report. I need the laptop today for a presentation, so for the moment I rolled back. Which worked …

Hmm. I thought about updating to beta1 but this doesn’t sound good and maybe i’ll try KDE4.5 when the RC is out. I want to test and help the KDE project but at the same time i want to have usable system.

As a preference you really need a dedicated machine for testing, that way, you don’t give a rat’s a-ss if it goes bonkers.

But kde 4.5 is nice for me.

I keep getting a download error from

download.opensuse.org/repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_Factory

both last night and this morning. I can access it with a web browser but neither zypper or YaST can connect.

Anyone else getting this or know of a mirror?

I found the gwdg mirror but I’m getting the same download error there.

The UNSTABLE repo still won’t sync with zypper or YaST. Does anyone have any info about this? Should I file a bug report?

I’m not getting this error

Weird. I just tried adding that repo in 11.2 and it worked fine. It’s just 11.3 Milestone7 where I’m having a problem.

Here is my repo list

zypper lr -d
#  | Alias                               | Name                                | Enabled | Refresh | Priority | Type   | URI                                                                                      | Service
---+-------------------------------------+-------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------------+--------
1  | Updates for openSUSE 11.3 11.3-1.53 | Updates for openSUSE 11.3 11.3-1.53 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                                                |        
2  | community                           | community                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_Factory/         |        
3  | factory_non-oss                     | factory non-oss                     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/non-oss/                                       |        
4  | factory_oss                         | factory oss                         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/oss/                                           |        
5  | gnome                               | gnome                               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Factory/openSUSE_Factory/               |        
6  | kde4                                | kde4                                | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_Factory/  |        
7  | kde4.5                              | kde4.5                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_Factory/ |        
8  | openSUSE-11.3 11.3-1.53             | openSUSE-11.3 11.3-1.53             | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/                                 |        
9  | packman_1                           | packman                             | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/factory/                                  |        
10 | repo-debug                          | openSUSE-11.3-Debug                 | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/                           |        
11 | repo-non-oss                        | openSUSE-11.3-Non-Oss               | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/                             |        
12 | repo-source                         | openSUSE-11.3-Source                | No      | No      |   99     | NONE   | http://download.opensuse.org/source/distribution/11.3/repo/oss/                          |        
13 | vlc                                 | vlc                                 | No      | No      |   99     | rpm-md | http://download.videolan.org/pub/vlc/SuSE/11.3 

The url I have is
Index of /repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_Factory

Can you brows to it OK

Have you tried a mirror
openSUSE Download Mirrors - Build Service

@Caf: I assume you have the 32bit packages running on the Lap#2. I’ve been working to get 4.5 beta to run on 11.2, and M7, both 64bit. Now back on plain M7 :wink: with 4.4.3. Which runs absolutely great on my laptop.

Indeed. 32bit

I rolled back to 4.4.3 and I still can’t add the UNSTABLE:/Desktop/openSUSE_Factory repo to Milestone 7 with zypper or YaST.

Since I’m able to use this repo in 11.2, it must have something to do with Milestone 7 or maybe the 64-bit version of M7.

I ran the latest updates to Milestone 7 today.