Testdrive not displaying fonts

Hi guys,
Just put together a Suse from KDE base and added in a load of stuff (apps, gnome, etc.) and when I did the test drive it wont display any fonts on the login screen and beyond. Is this a studio fault? Or is it my suse set-up? I’ve got what I perceive to be the standard fonts (the fonts package group and xorg-x11-fonts) plus extras selected in the software options.
Any clues?

Just to add, I can switch to text based view and that works fine, but obviously that’s not the point.

Hmm, no immediate worry. It seems it was something to do with adding the gnome desktop to the kde starter pack. I obviously didn’t add all the files it needed.

I have this exact problem, but using gnome
Can anyone help out ?
@bendare: what files where missing, it might help me to …

I booted on the live cd from my last image, the fonts in gnome where still only squares, in the live session i pulled up a terminal session with ALT+CTRL+F2
I typed in a few commands, basically these:

pango-querymodules > '/etc/pango/pango.modules

This solved the problem in the live session, now that makes me believe that one important install script are missing, but wich one ?
I can’t have whoever uses my image having to type these commands …

Don’t know exactly what package solved it, but it’s solved now anyway.
I’ll read my logs to see if I can figure it out. .