test audio works but no sound from any application

also without launching kmix when I reboot from yast>sound I have to delete nvidia card, click ok, edit and configure nvidia card, click ok, to have sound on my speakers…:slight_smile:
thnx, ciao, pier:-)

sorry, the contrary:
also without launching kmix, when I reboot I have no sound, from yast>sound I have to edit and configure nvidia card, click ok, delete nvidia card, click ok, to have sound on my speakers…:slight_smile:
thnx, ciao, pier:-)

So I have a couple PC’s with nVIDIA video cards that have sound. In YaST / Hardware / Sound, I just make sure the sound device I use, always a Creative Sound card, is device 0 on top, so its the default. No need to delete or unconfigure the nVIDIA cards. And, I go into …

openSUSE KDE menu / Configure Desktop / Hardware (Group) / Multimedia / Phonon (on left) / Audio Hardware Setup (Tab) / Sound Card: nVIDIA / Select Profile: Off

This is all I do and my Creative Sound card works just fine for me.

Thank You,

Under this thread - I raise my problem which is quite similar (may be minor) too …
For me also, I am not able to configure banshee/amarok/vlc players for proper sound.
While I check the sound in Yast / Hardware / Sound / Play Test Sound …everything
seems fine and volume levels are proper. However, when I switch to audio applications
such as banshee / amarok or vlc…no sound.
As per the instructions given above, I did all kind of trials. For me another point is :
(1) all these applications (banshee / amarok / vlc) play with proper sound in root user,
but in users, they don’t play !
Hence, I decided to add the users to audio group, but still no positive sign.
Can anybody help me please.

I am using Acer ASPIER 5920 Laptop with Open Suse 12.2 Linux 64-bit.

Till 12.1 version, this issue was not there.


What is master channel set as (in pulseaudio parlance, what is the “default sink” set as)?

Assuming KDE:

kmix > settings > select master channel


Finally my problem is fixed.

As I mentioned above, my problem was double folded:

(1) First, I was able to test the sound through Yast / Hardware / Sound / Play Test Sound …
and everything was fine here. However, there was no sound in Banshee / Amarok / VLC

(2) Later, when I did some R & D as per the discussion in this tread, I could understand that
the sound is absolutely fine in root user, thus my problem was surely something to do with
the permissions.

To solve this, I went to Yast / Secutiry and Users / Users and Group Management.
I selected my users and through edit mode, I added audio / pulse / pulse access groups to
the concerned users and gave reboot.

Finally…my sound is back with amarok / banshee and vlc.

Thanks to all the participants in the thread for sharing useful information.


I tried but no sound from speakers:-)

I tried the same but results no sound from speakers

all the channels at maximum and any master I choose results no sound from speakers
at the end I uninstalled pulseaudio and everything works as a charm, the difference in phonon is that now I have a lot of cards and the first is the one that works, when pulseaudio was installed the first card wasn’t the same as now, if it can help hereis a picture.