test audio works but no sound from any application

on my tumbleweed with kde 4.9.2, if I open yast control center>sound and I test my 5 Series/3400 Series Chipset High Definition Audio it works perfectly, but if I launch clementine, amarok, firefox>youtube vlc etc no sound comes out from speakers, if I launch pavucontrol the sound bar moves…

how can I solve???
thnx, ciao, pier :-))

If you have more than one sound device in your system, its possible that it is not set as the default. There are a couple of things to do. I do have two so I must configure PulseAudio so that the nVIDIA sound device uses the Profile of Off and in YaST / Hardware / Sound, I set my preferred sound device ahead of the nVIDIA sound device. In KDE for PulseAudio Look at Menu / Configure Desktop / Multimedia / Phonon / Audio Hardware Setup Tab / Hardware Profile. In YaST I go to System / Hardware / Sound and make sure my primary device is the default. I recommend to anyone they may want to look at these blogs on the subject:

Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums


S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.15 - Blogs - openSUSE Forums

Further, I have had good luck installing the xfce4-mixer from YaST which will load several things for it to work which is OK. It is more like the Alsa control of old and for each sound device you can add all controls it contains. For instance, on my Sound Blaster Card, in order to hear sound from my TV, connected to the Line-in, the Master, Front, Line-In and Analog-Mix volume controls all must be turned up even as they don’t show up in PulseAudio.

Thank You,

Ashamed to admit, but I faced same issue on my new laptop, I appeared to have muted the speakers with a keystroke …
Another option is to check the sound settings in KDE’s system settings.

On 2012-10-14 15:46, pier andreit wrote:
> on my tumbleweed

You should ask in the tumbleweed forum.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I don’t know what happened but last week sound worked :slight_smile:

ok it is so

ok, I made the profile off
but I noticed that in In KDE in Menu / Configure Desktop / Multimedia / Phonon / Device Preference
my Internal audio analog stereo is gray, (this is the one that should works, and phonon doesnt recognize?)
the high definitio audio controller digital stereo (HDMI) is now grey too (but I greyed it making the profile off)
simultaneous output is green

yes it is

I installed start too

me also installed now, and disabled kmix
but, how to put it in the dock where kmis was??

all controls are up

thnx, ciao, pier :-))

Unless you use xfce, I am not sure it can replace kmix in the system tray, but kmix should still be able to adjust the main volume control. From your last statement I was unable to determine if we had success or still no sound at the end of it all?

Thank You,

Give alsamixer a try, it should show all channels for all cards.

no sound :-))))
and also alsamixer everything is at max:-)

How about adding user to audio group, will that help/work?. YaST -> Users and Group Management -> Select user and click edit tab -> Details tab.
Give it a try.

added user to audio group, rebooted, no sound, yast sound test sound ok, pulseaudio volume meter shows that sound is produced but no sound happen, I think is a phonon or gstreamer problem
thnx, ciao, pier :-))

Play something (using whatever app; amarok, smplayer…). Open pavucontrol and select the Plackback tab. You should see the App listed and the associated soundbar should be moving. What audio device does it say it is playing on ? (e.g. Amarok: Music on … → Look on the right hand side of the pavucontrol window screen to see what is populated in the box). If its the wrong audio device (you seem to want the internal audio), click the box and select it from the dropdown list.

To the op,
Did you try to configure pavucontrol?
Sometimes even with sounds in yast2, if you miss the right
configuration, playback and output in pavucontrol it will not
yield a sound even if you see that the audio meters are working.
Try experimenting with the different options in pavucontrol and you might hit the jackpot.

Edit: With my experience with more than one sound device using pulseaudio, I noticed
that setting it to simultaneous sound works much better and all your sound device will
work simultaneously and you can control which one to use. I have the onboard, hdmi(nvidia)
and usb(bose) all working on my setup.

ok :-), clementine

ok, I can see clementine, the soundbar moves

I cannot see anything box populated at the right hand side of the pavucontrol window, here is a screenshot http://paste.opensuse.org/view/download/9850972

yes, I tried, but no success:-((

thnx, ciao, pier

What do the phonon settins in KDE say? I don’t mean whether it’s selected, but the Advanced Hardware settings. Had a friend over here yesterday, on his laptop’s everything in there defaulted to the HDMI output, setting it to the analog stereo output instantly produced sound.

Down the gui where you see Show: Applications
Click that application and try all streams and see what different options will show-up
and play with those

okay, I see what you mean lol!

What I want it to look like can be seen here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Though, the case in the oldcpu screenshot is a little convoluted because he has the pulseaudio eq running too. So a cleaner screenshot of would be similar to this: File:PA Volume Control playback.png - Audacity Wiki
In that one, the person has taken the screenshot just after clicking on the box populated by the “internal audio analog stereo”, and the resultant dropdown box has opened beside it, offering the selection of available audio devices (currently selected being bulleted)

You mentioned earlier that you set up a simultaneous profile ? (I’m not actually familiar with that)

I think is a phonon or gstreamer problem

This is what I believe is happening here too. And pier is on to something regarding an phonon issue – I identified an interaction irregularity with libcanberra in another thread.

On my way out right now, but, pier, try getting rid of the simultaneous output … I suspect that is why you are not seeing the audio device box in pavucontrol. Once you are able to actually select the preferred audio device, I suspect the issue will be resolved … i.e. something amiss going on in the background (read: phonon not getting it (the routing) right)

In the past, when sound worked in YaST (which has root permissions) and not in a regular application (which does not have root permissions) it would on occasion point to a permissions issue.

A work around that would on occasion work in that case, would be to add the regular user to group ‘audio’, and either restart the PC, or completely log out of the desktop and log out of GNU/Linux, and then after logging back in to test.

I have also read of users who updated from one GNU/Linux version to another, and indeed from one openSUSE version to another, keeping their old /home directory (which is what 99% of us do) and for some reason sound stopped working for the regular user (possibly a desktop issue) in which case a test was to create a brand new user and test the audio there with that brand new user.

Good luck, and apologies that I don’t have any magic solutions here. I note you do have Tumbleweed with KDE-4.9.2 and that in itself could be associated with the problem.

Solved, I don’t know why, but solved, I deleted the nvidia sound card from >yast>sound, after this the card become “not configured” (as in the picture)
and sound start to come out from my speakers…:-)), I suppose I will have no sound in hdmi card, but I never used it and I will face the problem when I will use…:-))
thnx to evrybody, ciao, pier :-))

It seemed solved…:), but, after some restart and update (I don’t know if they are responsible…), no sound from speakers, if it can help, I re-enabled the nvidia corporation card, click ok, and then re-delete it, and click ok again, to have sound again on my speakers, during this process kmix is closed by the process itself and disappear from the dock bar, I don’t know kmix is involved in the failure…:slight_smile:
thnx, ciao, pier:)