Terratec EWS88MT no sound


I have a Terratec EWS88MT sound card with external module (8 channels).
The problem is, there’s no sound coming out of it.

I realize it’s an older sound card, but under YaST-Hardware-Sound Configuration, it’s is recognized as:
“Index - 0, Card Model - EWS88MT”…
So i’m guessing the driver is alright?
If it’s not, what should i do? How do i get the sound to work?

The card itself has a 3.5mm analog output on it, and the external module has 8 inputs and 8 outputs.

Now, the amplifier is connected to the number 1 and 2 on the external module.
And how would i get all the channels to work for use in recording and playback? Is there a different driver or should i configure it in a specific way?

Please help. I don’t know what to do. I never had this card hooked up in suse, and my integrated card (which is now disabled in bios because i have this card in) always worked out of the box…

I never had to mess around with drivers and such, so i’m really new at this…

If you have more than one sound device, such as can be on a video card, have a look at my blog on the subject here:

PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

And my bash sound testing script here:

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.11 - Blogs - openSUSE Forums

Thank You,

Thank you!

I breezed through the text for now, i’ll read it in detail later, but this seems to be what i’m looking for!
Te channels pairs (1/2, 3/4…) on the sound device count as separate sound devices so this might help me configure it so the sound comes out of the channel i want.

I’ll try to set it up and see how it goes!

My PulseAudio Blog has a link in it to a nice blog from oldcpu on the usage of the pavuaudio application, which you should also read.

Thank You,

I can’t figure out what’s wrong…

In sound settings, the device is visible and configured properly (like from the link you provided):

Tnen i open Phonon and get this:


As if the sound device is disconnected…

In Phonon it’s not even listed properly (by name)…


pavucontrol doesn’t work (but lists the device differently, but not as EWS88MT)…

I found i have an Envy24 control panel which seems to be made for my sound card (reads it properly and lists all the available channels, just like the windows control panel that came with the card).
But nothing works, no sound whatsoever.

I have no idea what to do… :frowning:

And sorry about the full desktop SS, i forgot i could SS just one window. Later i re-opened Phonon but the window didn’t pop up again so i couldn’t screenshot it…


Any ideas what i’m doing wrong?

So it is early here in Austin and not much time to reply. When I see just the PulseAudio sound server and I have made changes, you need to restart your PC. If I see KDE ask to forget about a previous configuration, I also say yes. First, it will be redone for you automatically and second, there no need to keep a setup that is not working per KDE. I don’t even ponder why this comes up ever so often, but it is related to tinkering with YaST Hardware Sound and PulseAudio Sound Profiles.

Thank You,

Ok, i didn’t touch anything from yesterday, and when i booted in linux today, this is what happened so a reboot was required after all…
It didn’t ask me to forget the devices or anything either, and the visual equalizers work so the device should work.
No sound though. I’ll try messing with the settings but if you have any ideas, i would gladly hear them. :slight_smile:

EDIT: Oh, i forgot to mention that i typed ALSA in software manager and installed all the packages that weren’t installed.


I have found suggestions here to follow this: https://en.opensuse.org/SDB:Alsa-update OR [RESOLU] Carte m-audio (chipset ICE1712) avec pulseaudio (Page 1) / [Anciennes versions] Support général / Fedora-Fr - Communauté francophone Fedora - Linux](http://forums.fedora-fr.org/viewtopic.php?id=43836) which is not English, but perhaps the programming works anyway.

Thank You,

Good news! I finally got it to work! :smiley:

But not without re-installing the system which is ok, it was a new installation anyway, and i forgot to add a printer before so good thing i did it again. :stuck_out_tongue:

I downloaded Ubuntu to test if the card works there, and no, it doesn’t… Not right out of the box at least. And i’m not all that familliar with Ubuntu’s system to be able to configure it properly to work.
Then i re-installed Suse again, but with the Automatic configuration turned off…

In the update settings Yast2, during installation, i checked all the ALSA related stuff to install right away.
Then after it all updated, I needed to configure teh sound card manually (more or less).

I needed to disable! Pulse audio support (yes, idk why, the test sound wouldn’t play with that enabled…), and in the mixer settings i set everything to 75 since i didn’t know which 2 of the 50 displayed channels my amplifier was connected.

Now it works! For now. I hope it stays that way.
Suse intro sound plays, youtube plays, and all the channels are visible and work via Envy24 mixer for cards like mine. :slight_smile:

For some reason, if the card is not configured during install, it doesn’t work… Or makes a mess of your nerves as you try to figure out what’s wrong and how to get it to work…

Thank you very much for your help jdmcdaniel3!

I am happy to hear of your success and sorry for the troubles that you have had with sound. I can say that my approach for sound has just been to buy an add in sound card that works with Linux and to skip anything built-in. But you should be able to get what you have to work and it mostly does, but not always and some times extra effort, as in your case, is required.

Thank You,