Telus Compass 597 and OpenSUSE 11.2

Hey people, I been reading this forum for an answer as well as google.

I just finished my 11.2 install and trying to get my Sierra Compass 597 working, with no luck.

I downloaded the new sierra driver (version 1.7.12 for 2.6.31 kernel) installed it.

Then set up kppp as per these instructions

Connect to: WWAN
Login ID: user
Pwd: user

Accounts

Connection Name: WWAN
Phone number: #777
Authentication: PAP/CHAP
Use Lock File: checked
Callback type: None
IP: Dynamic
Gateway: Default
Assign default route
to this gateway: checked
DNS: Automatic

Modems

Modem name: ATT
Modem device: /dev/ttyUSB0
Flow control: Hardware
Line termination: CR
Connection speed: 921600
Use lock file: checked

  1. Insert Compass 597 USB modem and wait for kernel to see it.

user@Toshiba:~$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 004: ID 1199:0023 Sierra Wireless, Inc.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

user@Toshiba:~$ dmesg | grep -i ttyusb
usb 2-1: Sierra USB modem (3 port) converter now attached to ttyUSB0
usb 2-1: Sierra USB modem (3 port) converter now attached to ttyUSB1
usb 2-1: Sierra USB modem (3 port) converter now attached to ttyUSB2

  1. Then, enter the following commands:

user@Toshiba:~$ sudo modprobe -r usbserial

I get a FATAL error here, Module usbserial is in use, I tried with compass 597 in and out, neither works?

user@Toshiba:~$ sudo modprobe usbserial vendor=0x1199 product=0x0023

  1. Launch “KPPP” from “Applications” -> “Internet” and try to Connect. If works, should see something like this:

Here I get kppp can not find /dev/usb/ttyUSB0 Please make sure you have set up your modem device properly and/or adjust the location of the modem device on the modem tab of the setup dialog

I assume its because of the modprobe -r error, but not sure how to fix this?

when I do lsusb Sierra is at Bus 002 Device 008: ID 1199:0023 Sierra Wireless INC.

kernel is 2.6.31.5-0.1 x86-64
KDE 4.3.1 release 6

I’d just like to say, 11.2 is a gorgeous OS. Well done!

Thanks in advance for any help.

Just like to add that I tried this a different way, with Knetworkmanager, it works great, it recognizes the Compass 597 configures it, is able to use it, gets everything except for the IP address.

I need to be able to set the IP address to a static one, or if someone could tell me why it is getting the wrong one?

It has to be a certain IP, I messed with the tcp/ip settings on windoze, and the 597 quits working when I change the IP.

Alrighty, after 10 hours I finally got it, I’ll post how incase there is anyone else that needs this, cuz it sure is hard to find.

kInternet
smpppd

both are needed.

Then go into yast:

Software/System Services (Run Level) and make sure that smpppd is started.

Network Devices/Modem and add a new modem

Set the device to /dev/ttyUSB0 then hit next

Select Custom Provider then hit next

Provider Name can be whatever you want

Phone number for CDMA (Telus) is #777

Username and Password can be whatever, that is on the modem already.

Hit next, change what you want in there, or leave them as they are if you don’t know, and hit next.

Save the settings.

You may have to restart, then just right click on the kInternet icon in the bottom right hand corner, pick your interface and provider and click dial in.

Hopefully this saves you a headache, I know I have one.