Tecra M10 Sound Problems


I am relatively new to the linux world. This is my first post on these forums. I just got a new Toshiba Tecra M10 and opensuse 11 is going great guns…except for the sound.

lspci -v
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Toshiba America Info Systems Device 0001
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at ffcf8000 (64-bit, non-prefetchable) [size=16]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

uname -rp x86_64

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Here is a current listing of /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.MoRg9bR9p8C:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
options snd-intel8x0 ac97_quirk=4

This is the only option I have tried (outside of none). The mixer levels are all up (not muted) and still no sound.

I have no idea what to try next - maybe kernel upgrade? Any suggestions would be greatly appreciated.



Welcome to Linux and welcome to our forum.

Thanks for the info. A question: why did you choose the option snd-intel8x0 ac97_quirk=4 ? Unless you have a good reason, I recommend you remove that setting. Your card is an snd-hda-intel, and you have “told” it to load ac97_quirk=4 for an snd-intel8x0, which is not your laptop’s hardware/audio-chipset! Or is it ?

What alsa version are you using? 1.0.16 ? What desktop are you using? Gnome? KDE-3.5.9 ? KDE-4.0.4 ?

To provide the alsa version, please post the output of typing the following in a Gnome-Terminal or Konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2

For an ALC268 (and guessing you have 1.0.16 of alsa) I note the following options are available in the ALSA-Configuration.txt file:

	  3stack	3-stack model
	  toshiba	Toshiba A205
	  acer		Acer laptops
	  dell		Dell OEM laptops (Vostro 1200)
	  zepto		Zepto laptops
	  test		for testing/debugging purpose, almost all controls can
			adjusted.  Appearing only when compiled with
	  auto		auto-config reading BIOS (default) 

Now openSUSE-11.0 has a known bug for some hardware audio codecs (and I do not know if this is the case for the ALC268) it fails to auto recognize the hardware codec upon boot. So you could try the following in your /etc/modprobe.d/sound file:

options snd slots=snd-hda-intel
# u1Nb.MoRg9bR9p8C:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

and then restart your sound with su -c ‘rcalsasound restart’ (enter root password when prompted for a password) and test your sound (be certain to check your mixer). If that does not work, replace “auto” in that file with “3stack” (no quotes) and restart alsa (as described above) and test your sound. If that fails, replace “3stack” with “toshiba” (again no quotes), reload alsa, test … etc … also trying the acer, dell, and zepto options.

When it comes to testing your sound, I recommend you copy and paste the following into a gnome-terminal or konsole:
speaker-test -Dplug:front -c2 -l5 -twav

My reference for the above (except for the /etc/modprobe.d/sound file syntax, which varies from this reference for openSUSE-11.0) is the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Also, do you have ndiswrapper setup for wireless? That is also known on occasion to cause problems with the loading of the alsa driver on some PCs.

I tried the option snd-intel8x0 ac97_quirk=4 because someone had posted this setting on a blog for the satellite M10 model which has the same chipset.

Thanks for your speedy reply. The ‘options snd-hda-intel model=toshiba’ worked a treat.

How do you find out what options are available for a particular chipset?

To stay current I typically go to the alsa web site, and download the tarball, and extract the ALSA-Configuration.txt file from the alsa driver tarball. The information is in the ALSA-Configuration.txt file.

But you can also find the file by typing ALSA-Configuration.txt in google. The problem with the google approach is it can be difficult to determine what version of alsa the ALSA-Configuration.txt file might be associated with.

I almost forgot … CONGRATULATIONS !! :slight_smile:

I’m looking into buying a Tecra M10, and this post is my only hint that it will run well with Linux. Could you PLEASE send me more details of your experience, graphics in particular. I want to make presentations with an external display - have you done this? What about network and wireless?

Thanks in advance!

i plan to buy a Tecra M10 too.