Teamviewer 8/9 not starting OpenSuSE 13.1 64 bit

Hello everyone!

This is my first post here in the forums, so I hope I do everything right.

I have a problem with teamviewer versions 8 and 9 not starting on my machine.
Wine is set up correctly in my opinion and it launches TeamViewer.exe but the application itself is completely maxing out one thread:

Here’s the output of /var/log/teamviewer/TeamViewer9_Logfile.log
teamviewer 9 log opensuse 13.1 -

Has anyone an idea?
Could there be a porblem with my machine having hybrid-gpraphics as there are quite a few freedektop connect errors?
I have a HP Elitebook 850 G1 with:

  • Intel Core i7-4600U (2 Cores 4 Therads)
  • iGPU: Intel HD4400
  • dGPU: Radeon HD8750m, currently disabled with switcheroo

Thanks in advance!

Regards, Paul

Same here

Start: 2014/03/11 12:48:25.445 (UTC+2:00)
Version: 9.0.24147
ID: 0
Loglevel: Info (100)
License: 0
IC: -1389844697
CPU: Intel(R) Core™ i5-4670 CPU @ 3.40GHz
CPU extensions: h9
OS: Lx openSUSE 13.1 (Bo (32-bit)
MID: 0x0a0027000000_2823c0b8_d41d8cd98f00b204
MIDv: 0
Proxy-Settings: Type=1 IP= User=

uname -a
Linux AT-AT 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux

Did you install it like this;


Then run; zypper in -y teamviewer_linux.rpm

Zypper will install the necessary dependencies and this will allow you to easily upgrade Teamviewer in the future with an RPM.

I just tested it in a 13.1 VM and it seems to work fine.

@OP: you’re taking the wrong steps. When looking for / wanting to use software:

  1. Yast’s software manager
  3. Manufacturer rpm’s using zypper. Rather find someone, that will build proper openSUSE packages, but stuff like Skype, Google Earth etc. can be installed this way
  4. Compile from sources
  5. Use wine to run the windu version.

Yes, I’ve done that. First tried apper which didn’t work then tried zypper in shell, also no luck.
Teamviewer runs fine on my Arch/Debian/Ubuntu boxes though.

Thanks for the advice but

  1. No package in the main Repos
  2. No package in the community Repos
  3. Is the one I’ve tried with no luck
  4. Can’t do that as it’s closed source
  5. Windows-Version on WINE get’s blocked from the TV-Servers as it’s not official

Any ideas?