TeamViewer 10 / Failed To Wake Up Error


Recently, I have been trying to make a Database at home. And what I have tried is TeamViewer 10 (should be the latest version), and what I want to do, is to use Wake-On-Lan (WOL), though I am not having much success.
My error that comes up is: failed to wake up [name of computer]
I have configured only Teamviewers settings (so I did not go into the BIOS yet.).
Why do I get this error, and how can I connect from Site A to Computer C (while Computer C is in another network and location).

Cheers & Thanks,

And the version of openSUSE is …?

I am using the latest version of Tumbleweed.

Uname -a

Linux 3.19.3-1-desktop #1 SMP PREEMPT Thu Mar 26 17:34:34 UTC 2015 (f10e7fc) x86_64 x86_64 x86_64 GNU/Linux

I put this here to be even more precise.

Cheers & thanks,

Then, why isn’t this in the Tumbleweed forum?

On 04/05/2015 01:46 PM, hcvv wrote:
> Arpadius98;2703220 Wrote:
>> I am using the latest version of Tumbleweed.
> Then, why isn’t this in the Tumbleweed forum?

Because not every program is tied to TW just because it is installed in TW.

Stop being such a TW nazi.

A program failing in Tumbleweed may very well have something to do with Tumbleweed. Or at least the version of the software stack on tumbleweed.

I don’t use Tumbleweed and thus can be of no help to someone that is. Whole different software stack. Why are you wasting my time???

If you run Tumbleweed please post all question in the correct forum :frowning:

hcvv and gogalthorp,

I am truly sorry for my mistake. But I would like to ask, wouldn`t TeamViewer run the same way on OpenSUSE 13.2, Tumbleweed, Windows, and Mac? I have a question about the system, it is not an OS problem I have. I have posted this here, since I have a question about the application itself (using the application, how to use the WOL [Wake-On-LAN]). The way I know, this program runs the exact same way (and works the same way) on all 4 OS mentioned above. So my reasoning to post it here, is to ask someone if they know how it works. So this post does not have much correlation to the OS, but it is here for assistance on using the program itself. I am having trouble using WOL to connect my 2 computers together. I have been using this program on Windows and OpenSUSE, they work the exact same way.

Main Point: This post is for the program on how it works (I need help using it), I do understand your point that it should belong to the "Tumbleweed forum, but in this program, you need to configure the BIOS to allow WAL, and then download the program and using the program is where I have the problem.

Then again, there might be a problem with the system (but I dont really think so. Though I value your opinion more than mine, since you know a lot more about OpenSUSE than me). I can see your point that it should belong to the "Tumbleweed" forum. I posted it here, because I did not see much correlation to Tumbleweed (sounds stupid of me to do this, but if the program runs the same everywhere, I dont see much reason of having it there).

My apologies,

You must remind that you are asking a question. You have a problem and you did already look at it from all the sides YOU can imagine. Then you ask for help. One of the main reasons one asks for help, is because other people may look to your problem from a complete different starting point and thus see what you do not see. You did not see it, because when staring at your problem for so long, you are struck by some blindeness, making it impossible for you to see the other approach. That is human. We all suffer from it and thus are glad that we can call others for help.

To let this process be successful, you should provide as much (background) information as possible to your potential helpers. Specially that information you think is irrelevant. Else your bias in looking at your problem will be forced on others.

And you are here long enough to know that people like to know which software versions you use. Specially the operating system itself. And when you then (willfully or not) do not tell which version of openSUSE you use, you may be glad that people (again) take te trouble to ask it from you. Many people will simply think: Oh, it is him again, have to ask for the most basic info again, may take days, sun is shining, I go out for a walk.

You also seem to ignore the fact that people will possibly try to re-create your problem in one of the systems they have. Many have several openSUSE versions running in e.g. Virtual boxes. How can they re-create in the correct version when you keep silent about it?

And this is even more the case with Tumbleweed. Many people just run a stable openSUSE version as released and maintained. They are not interested in Tumbleweed, never used it, not really thought about using it ever and do not really know what the finer details about it are. They simply feel themselves not qualified to say anything useful about it. And as you have seen, good and valued members here are really frustrated when someone then asks them for help and does not say the problem is found using Tumbleweed. And there is one thing we not want, and that is that valued members stop helping people here because they are spoiling their time because people hide crucial information for them.

We created the Tumbleweed forums for the Tumbleweed users. As a Tumbleweed user, please use it. And when you think that you need assistance from people using the standard distribution, then first re-create your problem with the standard distribution.

And last but not least, you may find useful information here:

And to give some most probably version independent advice about WOL:

First try WOL outside any big application. Using wol, see

man wol

And of course check if the system can be waked up and how

ethtool <device-name> | grep Wake

(were <device-name> is eth0 or a new name like enp1s8)


The link you sent me, I find it rather hilarious…


Hello Arpadius98,

I find your thread because i wass searching something else on your other thread (speeding up linux).

I have to tell you that you do it the wrong way, i mean using a windows tool with a linux distro is not the good way…
To do remote acces to a linux sytem use linux (opensource) tools !
Search on your distro for “remote”, i think you should get at least 4 very good tools to do something you want…
If you don’t find ask for the work to be done not why it’s not working (in this case because it’s the wrong tool).
Are you searching for a “server”, a remote “database”, a “BBS” or a “remote desk” ? is there a Team on a local network or just you in the net ?

Hope you find quickly the right tool and by the way the kde’s remote tools have mainly k in the begining of the name.

Cheers Ursh15

Ps: if you use teamviewer for your job, you have to register and if you did, the teamviewer technician’s are very efficient, in 2009 the solved a big problem in about 2 days for some costumers (a big city with DMZ).


First of all, thank you very much for finding this thread as well to tell me about TeamViewer. I read your other post as well on “Speeding Up Linux” (in-fact I read it nearly after you posted it, just hadnt had time to write back). The reason why I use TeamViewer is because it has worked very well in the past (with Windows 7), and now in Linux it just doesnt want to work at all, I have configured the WOL (Wake-On-LAN) in the BIOS, then in the program itself (and this is all that is needed, and then everything worked).

So, I guess I have to use Plan B (using something else than TeamViewer). Any ideas on what I can use to wake up and remotely control a computer from another network? I checked out the standard KRDC (KDE Remote Desktop Client), though I would like something simple (in computers, I know nothing, everytime they ask me for information I have to google it, unless it can be found easily in the start menu or yast). So something simple like TeamViewer, TeamViewer is very easy to use, that is why I sticked to it, so a program/application similar to TeamViewer would be great. I will be searching some, I will notify everyone on this thread if I find one.


The commands you told me to use to wake up a computer worked great! Though one problem, when I tried it on a different network it did not wake up, and when I came home there was no sign that the computer ever did turn on. I would like to wake up the computer, the rest of the problems are all solved by TeamViewer (the remote desktop thing in TeamViewer works great, same with file transfers, except waking it up). I have a friend, who said he did not need to configure anything and teamviewer WOL worked for him (both computers were in seperate networks [using different routers]), though again, unfortunately that was on windows.

Cheers & Thanks again,

I believe you have to allow access via the Firewall settings. And the ports must also be open on your router

Hello Again,

Just for information, teamviewer and windows interact with the bios (that’s why it’s working out of the box on not to old pc)… if you insist with wol and teamviewer on a linux distro you have to give acces to the bios (i don’t recomand) look at the teamviewer site !


There are a few different methods of WOL. But most rely on ethernet functionality, and thus can not leave the LAN). Only WOL based on IP address might ve routed, but I doubt that many systems will use it.

I assume that you read that part of the man page of ethtool that explains which WOL methods exist and tat you found out which of them is supported in your case (amongst those of course the one you tried succesfull).

I assume you have read, which start saying it is ethernet (thus not TCP/IP).


So I must configer the router and the firewall settings to allow it? Though, why does TeamViewers WOL (via public address) not work on Linux? Why would they release an update of Teamviewer which doesnt even work properly?
The reason why I would like something that is just like TeamViewer is because with TeamViewer all I had to do is just 3 button clicks and it was already got to go. I am at the moment fiddleing around with the KRDC (KDE Remote Desktrop Client), trying to get it to work (no idea how it works).



Sorry, I forgot to ask last time, how in linux do you get the address in this syntax:

 The entered address does not have the required form.

  Syntax: [username@]host:port]

Where do I find the host? Or create the computer as a host? And then the port? Which port is recommended?
I tried to write it in the correct way, but it did not work at all. How do I enable this KRDC thing and then connect to the computer from another network.


How would we know ask the TeamViewer folks…

I assume host is eitjet a resolvable hostname or an IP address.