TD Ameritrade Thinkorswim (TOS) trading platform on opensuse 13.2 x86-64 success

1st, I’m no expert, so bare with me as I try to explain the steps I had to go through…I’ll add some key tips…I omitted my failures…

2nd. I got the Linux TOS installer,, by going to TD Ameritrade in Firefox, login > Thinkorswim > download and it automatically provided the Linux version.

3rd, the open-source java-1.7 w/icedtea and java-1.8 installed by default does not provide the file “JavaFX” needed by the TOS installer – I needed the Oracle Java.

Tip: The TOS installer is written for java-1.7, so google for that; my download was “jdk-7u72-linux-x64.rpm”. (the direct Oracle site will come up with the latest = java-1.8) For security reasons, only get it from Oracle!

I went into YAST and deleted all related to java-1_7 & 1.8. I tried to delete java-1_5_0-gcj-compat, but, Yast complained of broken packages, so, I left it.

I installed Oracle Java as root, with

# cd /home/user/Downloads
 # rpm -ihv jdk-7u72-linux-x64.rpm

 	 	 	   Tip: it installed to /usr/java.  Plus, I did not delete any /usr/lib64 jvm or java folders

Still in root, using the SuSe guide, I then did:

# update-alternatives --install "/usr/bin/java" "java" "/usr/java/latest/bin/java"  
 # update-alternatives --set java /usr/java/latest/bin/java

update-alternatives: using /usr/java/latest/bin/java to provide /usr/bin/java (java) in manual mode

 	 	 	   Next, I had to set the path:
   	 	 	 	# JAVA_HOME=/usr/java

 # export PATH=$JAVA_HOME/bin:$PATH


Close out of the root terminal

In /home/user, I made a folder = TOS and moved “” into it

Next in a user terminal (don’t install it as root for java security reasons)

> cd /home/user/TOS
 > ./

 	 	 	   It will install to /home/user/thinkorswim and add an Icon to the desktop (neat)!

Launch thinkorswim; it should work!

Tip: Give it time to build the virtual machine and get updates = be patient, wait…

Tip: it built the VM on my primary screen where all my controls are and when I tried to drag it to my left screen, it crashed. My solution was to minimize it, right click it on the taskbar & select “move”; now it works on 2nd screen & frees up my primary screen

Tip: After all this, Java did not work in Firefox (google for java test), so, I went back into Yast and reinstalled all of java-1.7 & tabooed all of java-1.8; now Java works in Firefox too in addition to TOS (my logic was that the TOS program was installed and path set, why not.)

Works for me! Have fun.