Targus bluetooth dongle shows to be working, but will not connect

My Targus BT adapter always worked in Leap, up to and including 15.4
I upgraded to Tumbleweed and although it shows to be working, it will not connect nor will it accept a connection. Using bluedevil5 5.26.2-1.1 over bluez 5.65-4.1 the devices see each other and present matching pins, but the setup fails. After failure, both devices appear in the device list of the opposing device. When I try to manually connect, I get:


dmesg output after hot plug is:

  1304.555453] Bluetooth: hci0: BCM: chip id 63 
 1304.556451] Bluetooth: hci0: BCM: features 0x07 
 1304.572519] Bluetooth: hci0: BCM20702A 
 1304.572522] Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000 
 1304.573473] Bluetooth: hci0: BCM20702A1 'brcm/BCM20702A1-0a5c-21e8.hcd' Patch 
 1305.385613] Bluetooth: hci0: BCM: features 0x07 
 1305.401501] Bluetooth: hci0: Broadcom Bluetooth Device 
 1305.401505] Bluetooth: hci0: BCM20702A1 (001.002.014) build 1338 
 1305.455700] Bluetooth: MGMT ver 1.22

I do have a similar device

**#** dmesg | grep Bluetooth 
    3.959281] usb 2-3: Product: BCM920702 **Bluetooth** 4.0 
    6.074823] **Bluetooth**: Core ver 2.22 
    6.078233] **Bluetooth**: HCI device and connection manager initialized 
    6.078235] **Bluetooth**: HCI socket layer initialized 
    6.078237] **Bluetooth**: L2CAP socket layer initialized 
    6.078239] **Bluetooth**: SCO socket layer initialized 
    6.285049] **Bluetooth**: hci0: BCM: chip id 63 
    6.288093] **Bluetooth**: hci0: BCM: features 0x07 
    6.306471] **Bluetooth**: hci0: SYSTEM1
    6.309699] **Bluetooth**: hci0: BCM20702A1 (001.002.014) build 1338 
    6.313023] **Bluetooth**: hci0: BCM20702A1 'brcm/BCM20702A1-0a5c-21e8.hcd' Patch 
    7.045063] **Bluetooth**: hci0: BCM: features 0x07 
    7.063063] **Bluetooth**: hci0: Broadcom **Bluetooth** Device 
    7.064996] **Bluetooth**: hci0: BCM20702A1 (001.002.014) build 1338 
   16.212058] **Bluetooth**: BNEP (Ethernet Emulation) ver 1.3 
   16.212062] **Bluetooth**: BNEP filters: protocol multicast 
   16.212065] **Bluetooth**: BNEP socket layer initialized 
   16.213294] **Bluetooth**: MGMT ver 1.22 
   39.140835] **Bluetooth**: RFCOMM TTY layer initialized 
   39.140868] **Bluetooth**: RFCOMM socket layer initialized 
   39.140879] **Bluetooth**: RFCOMM ver 1.11

and have those packages installed

# zypper se -si blue*
Loading repository data...
Reading installed packages...

S  | Name             | Type    | Version    | Arch   | Repository
i  | bluedevil5       | package | 5.26.2-1.1 | x86_64 | openSUSE Tumbleweed Oss
i+ | bluedevil5-lang  | package | 5.26.2-1.1 | noarch | openSUSE Tumbleweed Oss
i+ | bluez            | package | 5.65-4.1   | x86_64 | openSUSE Tumbleweed Oss
i+ | bluez-obexd      | package | 5.65-4.1   | x86_64 | openSUSE Tumbleweed Oss
i  | bluez-qt-imports | package | 5.99.0-1.1 | x86_64 | openSUSE Tumbleweed Oss
i  | bluez-qt-udev    | package | 5.99.0-1.1 | x86_64 | openSUSE Tumbleweed Oss

and kernel-firmware-bluetooth 20221031-1.1 is installed as well. The device works fine.

In case it’s only the file transfer via bluetooth that is not working on your system: have a look here.



Thank you. Very helpful. I see that users reported that obex was not installed as an associated app back in April. Hopefully they will make it a prerequisite for bluez soon. I installed it manually. I set up the “systemctl --user start obex” command as a startup script in Plasma. Problem is solved.

You can do (as a “plain” user)

> systemctl --user enable obex 
Created symlink /home/USER/.config/systemd/user/dbus-org.bluez.obex.service → /usr/lib/systemd/user/obex.service.

and the service should be started automatically on login (so no need for a startup script).