Tablet mode with kde, tumbleweed, yoga 530


I have a Lenovo yoga 530, bough second hand some month ago and around 3 years old.
I run on it tumbleweed with no real problem.

However, when going out of hibernation, It comes in tablet mode and I don’t know how to go out of it. I have to kill the session (ctl Alt and two backspaces)

I almost never use tablet mode. All hits from google don’t give me hints. I didn’t find any “tabletpc” thing from YaST.

Any doc about openSUSE Tablet mode on Kde (updated one hour ago)


had the same issue with an old dell inspiron touchscreen laptop… I never got round to fixing it because I never really had the time but in theory, you could ether:

  • dissable hibernation
  • dissable tablet mode in kde [even better in your bios if itis fancy enough to have the option]

I never figured out if my touchscreen worked in this state because it was dead but you could try and fold it into tablet mode and back into laptop mode if it is not completely frozen.

I believe it is an issue with the tablet mode detection drivers - for lack of a better word - so it is probably best do dissable features arround the isue untill you figure out what you can live without that solves the features. Ultimately, I would reccomend submitting a bug report to both opensuse and kde in the meantime.

you should also check if the issue is just with hybernation. can you remember if you enlarged swap size for hibernate or if you ever intended to enable hibernate, if not your issue could be because kde will try to force you into hibernation but it is not fully suported or compatible with your system. to disable this - you can go into your sleep and screen off setings and switch the option that dictates what happens when your laptop is closed for x ammount of time…
Hope this helps and you can figure out this bug…
Luca :slight_smile:

problem is that I don’t know how to do this (I never u tablet mode). Any hint? (nothing relevant in the bios)


I have to add that I just verified that I have “power off in lid closed” in config (no hibernation), so the real problem is that the computer do not power off when lid closed :frowning:

I may open a bug report (but next week, I’m not at home right now)


just checked and cant seem to find any options about the strange tablet only mode… my recomendation would be just to dissable hybernate and make a bug report on the kde website to see if there is an alternative fix…