T61 opensuse 11 - brightness (fn) keys don't work correctly

I am running 11 GM on my T61. I use the Fn+brightness keys to adjust brightness and they don’t work correctly. I’ll press up on brightness and the OSD shows it going down and vice-versa. Also, when plugging back into a dock after going mobile, the brightness doesnt’ go back up to 100% as expected.

Anyone know of fixes for this or do I need to open a bug? Seems like a pretty large issue to have made it through the Alphas and Betas.

If you installed via the 1cd livecd’s you may want to use the dvd image and see if it helps…on my dell laptop function f8 is not switching to the external monitor when docked…I filed a bug on it.

Nope, I installed using the DVD - running GM now.

On my T61 the Fn-keys seem not to work at all. Screen brightness is all the way up all the time. There is no OSD.
If I pull the plug of the power adapter though, the screen dims a little.

Surprisingly, the Fn-keys work correctly when the GRUB menu is displayed but stop functioning when OpenSUSE 11.0 runs.

I don’t know how to file a bug but I think I’ll have to find out…

When I open a console and run

xbacklight -set 20

the screen dims correctly.

xbacklight -set 100

brightens it again.

At least a workaround.
I found this on the Linux-Thinkpad mailing list.

There was an ongoing problem with thinkpad Fn keys & buttons on the T60/61 and related Lenovo laptops in the betas & RC1 (see bug 382855). While there was some improvement in the thinkpad buttons issue (e.g., volume & mute were fixed in RC1), a number of the Fn buttons were left unfixed before the public release of 11.0 since they were probably deemed not to be show stoppers. The good news is that there is already an open bug on this, so the devs know about it. You can update the bug as not working in 11.0 and add yourself to the e-mail list to follow the problem (the log-in for bugzilla is the same as for this forum btw).

There have been a number of these types of bugs in testing beta 3 & RC1 on my T60 that have lead me to at least wait a bit for some fixes as updates before jumping from 10.3.

See if installing the hotkey rpm from Yast Software Management fixes the problem.

I’m not sure if there’s a hotkey rpm suitable for my Thinkpad.

On my Inspiron 1525, with 11.0 the brightness keys and some other FN-Keys don’t work.
I installed a 10.3 system in parallel, and all the FN keys work. I double checked that the same keyboard layout is used.
So I think it’s a 11.0 bug.

On my Thinkpad T61p, the LCD dims and brightens depending on whether it is active or not (in both Gnome and KDE4,running on AC or battery).This is done automatically by the powersave software.I have not used all the function keys, though I know that Fn(F4) does suspend and resume. I have another problem, not related to the functions keys, but the wireless antenna button. It does not come come on when connected to a wireless network. This used to work on Fedora 9. I wish I could get it working, though it is not a big deal, it would be nice to have it.
I’m still looking for the perfect distribution for my laptop, but I like Suse and know that its developers are constantly working on making it the best distribution for laptops, so I’ll wait.

Sorry to confuse things, but my Inspiron 1525 with 11.0 has the Fn brightness keys working OK.

That’s really confusing. Maybe to be a bit more specific. The brightness keys does work somehow, but they produce only a flickering that sometimes dims or brightens the display but not in a very steady way or it jumps back to the previous setting.

Can you give me some details about your installation?
Which keyboard do you have chosen in SaX2?
Which kernel do you have installed?
Or do you remember anything else what you have done in addition to the standard installation?

The keyboard type is a Microsoft Natural Keyboard Pro/Microsoft Interne, layout is United Kingdom, and variant is basic. No options are set. These settings were the ones from the DVD install.

The kernel is

Don’t think I have done anything different. Will be able to confirm that as I am about to do a re-install to get my wireless card working - I had it turned off at install!

I have a Sony Vaio and I had the same problem. My fn button never worked.
Go into terminal and type the following: (Don’t forget the little slash before “set”)
xbacklight -set ## <-----percentage you want your brightness to be
This should work.


I also have a Thinkpad T61 running openSUSE 11.

The laptop came with preinstalled SLED10, and the Fn keys works in SLED10.

But with openSUSE11 the brightness Fn keys do not up or down the brightness level, but I can see that they do trigger a event, here is a message in /var/log/messages after pressing Fn+Home and Fn+End:

Jul 14 20:20:52 linux-ysg5 logger: thinkpad_acpi_events Custom event script for ThinkPad thinkpad_acpi driver

Jul 14 20:20:52 linux-ysg5 logger: thinkpad_acpi_events Fn+Home hotkey: keycode 128 serial 4112. action: brighter display
Jul 14 20:20:53 linux-ysg5 logger: thinkpad_acpi_events Custom event script for ThinkPad thinkpad_acpi driver
Jul 14 20:20:53 linux-ysg5 logger: thinkpad_acpi_events Unidentified hotkey: keycode 128 serial 4113. action: log event

I can also see in /proc/acpi/ibm these files:

/proc/acpi/ibm # ls
beep bluetooth brightness cmos driver ecdump fan hotkey led light thermal video volume

The brightness file appeared after I load ‘thinkpad-acpi’ with the parameter: brightness_enable=1

This is how I load ‘thinkpad-acpi’ module in ‘/etc/modprobe.d/thinkpad_acpi’ :

options thinkpad_acpi brightness_enable=1 experimental=1 hotkey=enable,0xffffffff

The kernel know when I press the brightness keys but I think there is no program handling it.

The volume keys are working beatiful and a graphic OSD message appears when I use them.

But the brightness think is very important too, I hope somebody help us.


OK - The function keys are now working. The reason is not a bug, but a change in way the FN keys are handled. Before 11.0, openSUSE shipped package hotkey-setup. But with 11.0, they switched to HAL to enable the keys. (Details in a bug-ticket at openSUSE: Login). You still can install hotkey-setup for 11.0 from the PackMan repository. But you can also enhance the keymapping file in /usr/share/fdi/information/10freedesktop/. For each manufacturer you can find an XML file containing the keymappings of their models. unfortunately this is not yet complete. I added an entry in 30-keymap-dell.fdi for my Dell Inspiron 1525. You can find my file in new bug http://bugzilla.novell.com/show_bug.cgi?id=410174.

For the problem with the not properly working brightness keys: Try setting module video to the blacklist in /etc/modprobe/blacklist. At best, restart your system after changing this file.

I had installed hotkey-setup from packman but the brightness function keys still don’t work.

I haved blacklisted ‘video’ module and restarted the system but Fn keys for brightness still don’t work.

But kpowersave, xbacklight and other utility for handled the brighnes do work.

But I really need the Fn for brightness work, because is really annoying open a terminal and execute ‘xbacklight’ for example to change the brightness.


On my machine I successfully tried the following:

Ctrl-Alt F2 (this opens the console)
Fn-Home (this increases the light as before and as in Grub)
Ctrl-Alt F7 (this switches back to my X11 screen)

This is definitely not a nice solution but it at least seems to work.

hmmm … don’t work eather in the console.

In Grub the brightness fn keys do work, just after booting linux (in the kernel loading) these keys stop working.

T61 + openSUSE11

The same problem occurs on my hp compaq 6735b none of the buttons except mute and wireless button work.what should I do?