T61 Intel GM965) without the cube?

Hello everyone!

I am totally new to Linux, migrating from Windows on my own (no friends etc who have Linux - so no help). I do not know much about the inner workings of operating systems and nothing about programing so these questions might be totally stupid, but I have not been able to figure out a solution after countless hours of trial and error.

I have a ThinkPad T61 with the Intel GM965 graphics card. The T61 came preloaded with SLED 10 but I did not get the cube working (i was unable to activate XGL for some reason). Now I have installed openSUSE 11 instead and added Compiz Fusion but I still can’t get the cube working. I have tried both the KDE 3.5 and 4 if that makes any difference.

I first enable desktop effects in the Simple CompizConfig Settings Manager. When I then activate the 3d cube it says that I must disable Windows Wall and enable GLX, which I then do. Everything looks fine but when I open up to check again the cube is deselected. Nothing else works either (wobbly windows etc.).

Please any input on this would be greatly appreciated,


works perfect 4 me. You obviously did not edit your /etc/X11/xorg.conf file with kwrite or kate as root user by adding the line below to the very last part of the file.

option “composite” “enable”

also make sure you use Yast sysconfig for setting the display to xgl from X11.

*enter these commands in terminal to do the first part above.
kwrite /etc/X11/xorg.conf

When finished, save the file and exit!


If it does not work after reboot, then go back into terminal NOT AS ROOT! and enter < fusion-icon >

good luck.

Hi and thank you for your answer.

I did the following:

in the terminal i entered:
and then
kwrite /etc/X11/xorg.conf


In terminal, not as root, < fusion-icon >

It seems that nothing has changed. When I enable desktop effects in “Simple CompizConfig Settings Manager” the Desktop cube is deselected and vice versa.

Maybe I just have some setting completely wrong. As I said I am totally new to this and would repeatedly appreciate help.