t3500 dell workstation no sound

I have a t3500 workstation at work that has no sound output. This is an issue on all the t3500’s we have. I am fumbling through trying to figure it out but I am relatively new to suse and don’t know what to do next.

I bet this wouldn’t be a problem in the latest suse but I have to use suse 10.3 for the workstations development environment, so i cant update from there.

I did go through the guide Alsa-update but it didn’t fix the problem. Still no sound.

Doesn’t seem to be much out there about the t3500 dell so i am pretty stuck At the moment. Any help would be greatly appreciated.

I would like to try help you , but I know nothing about your hardware. Please, can you thus provide the information that is recommended to be provided from the 2nd half of our multimedia stickie: Welcome to multimedia sub-area - openSUSE Forums

and I’ll quote that for you:

please post … providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

thanks for the directions. getting all the info and i will post it back.

http://www.alsa-project.org/db/?f=c5f23c888791bd7329e95f29ad4084b5010e9d16

alsa-oss-1.0.14-23
alsa-utils-1.0.14-27
alsa-plugins-1.0.14-41
alsa-firmware-1.0.14-24
alsa-1.0.14-31

in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here no output from this command

libasound2-1.0.14-31

Linux WS-76682 2.6.24-smpdev #1 SMP Wed Sep 16 16:03:50 PDT 2009 i686 i686 i386 GNU/Linux

alias snd-card-0 snd-opl3sa2
alias sound-slot-0 snd-opl3sa2
options snd-opl3sa2 fm_port=-1 midi_port=-1 port=0x370 wss_port=0x530 isapnp=0 dma1=1 dma2=0 irq=5

cat: /etc/modprobe.d/50-sound.conf: No such file or directory

that surprised me.

Then I saw this:

!!Kernel Information
!!------------------

Kernel release:    2.6.24-smpdev
Operating System:  GNU/Linux
Architecture:      i686
Processor:         i686
SMP Enabled:       Yes

what kernel is this ? Does this come with 10.3 ?

then I noted this:

!!ALSA Version
!!------------

Driver version:     
Library version:    
Utilities version:  1.0.14

this shows your 1.0.14 version of alsa is not able to load a driver, likely because your hardware is not supported by 1.0.14 of alsa.

But really, openSUSE-10.3 is not supported any more.

Hence I am very limited in what I can propose. For 11.0, 11.1, and 11.2 there are updated alsa versions, but there is nothing for you on 10.3.

If you insist on staying on 10.3, then you will have to compile alsa yourself: Main Page - AlsaProject

ie:

  -   alsa-driver-1.0.22.1
  -  alsa-lib-1.0.22
  -  alsa-utils-1.0.22
  -  alsa-tools-1.0.22
  -  alsa-firmware-1.0.20
  -  alsa-plugins-1.0.22
*] alsa-oss-1.0.17

thank you for the reply. Yes for now 10.3 is the only version we can use for the dev environment.

I will pass this along and see if maybe we can force an upgrade or compile the alsa ourselves.

I appreciate how fast you responded, thank you again.

I just had the same problem on a T3500 with Fedora 12. Try hitting F2 during boot to access the BIOS, and from there, you can enable the audio chipset via a checkbox in one of the menus.