Sytem not recogniziong /dev/ttyUSB* ports

I am using Leap 15.2 with AMD Athlon CPU. The system is not recognizing attached USB devices. The problem appeared from nowhere as it was working 3 days ago. Further, altho the is a /dev/ttyUSB0 device, assigning the Arduino to that port does not work and I question if /dev/ttyUSB0 is actually functional.

The devices are a Arduino and a Digilent Nexys FPGA board. Needless to say I cannot program ether device and my development efforts are at a standstill until the problem is solved.

I would like to fix it so the attached USB devices are recognized at boot time, but in lieu of that solution, how does one mount these generic devices?

Many thanks,


various commands:

ls /dev/ttyUSB*

3 days ago I had /dev/ttyUSB0 /dev/ttyUSB1 /dev/ttyUSB2

dmesg | grep tty
0.000000] printk: console [tty0] enabled
2.501118] 00:02: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
6.906187] usb 6-4: cp210x converter now attached to ttyUSB0

When you are sure that you did not update the system (or installed new osftware) since it “worked”, I am always inclined to say “check the hardware”. But I assume you did that already.

As Henk has speculated, this may well be a hardware issue. At the very least you should run dmesg in a terminal

dmesg -w

and observe/capture the output while plugging in the device. Report back here with that output. Please use CODE tags when posting such commands and output. (Refer to the ‘#’ button in the forum editor.)