Systemd waiting for non-critical disk, hangs boot.


I have three disks in my system, which are mounted as follows:


From time to time, I swap the windows disk with another disk to recover files/dd the disk using my Suse install. The old init system didn’t care whether this disk was present at boot time (it would simply raise a warning in the system log), however since upgrading to 12.1 (which now uses systemd) the system decides to wait indefinitely until it can find the missing disk, and if it can’t it raises a warning and then presents me with an emergency mode login.

In order to actually boot without this disk, I have to use said emergency mode to comment out the windows disk entry in my fstab and then reboot. As you can imagine, this is highly inconvenient. This is not a system critical disk like the root disk or my /home disk and thus it is not needed at boot. How can I tell systemd to not wait on this disk during boot?


Try the nofail option in the fstab entry of that disk.

This worked perfectly; thank you.

yoou are welcome. It is from

man 8 mount