systemd-vconsole-setup.service fails to load since installation


During installation I changed the keyboard layout of the live system from what seems like the default (after I had selected UK English, as I’m Australian with a preference for UK English as it’s closer to Australian English and US Keyboard) of that of Great Britain to that of the United States. Since installation every boot up systemd-vconsole-setup.service fails to load. If systemctl status helps it is here:

● systemd-vconsole-setup.service - Setup Virtual Console
   Loaded: loaded (/usr/lib/systemd/system/systemd-vconsole-setup.service; static; vendor preset: disabled)
   Active: inactive (dead) since Wed 2017-12-20 18:29:55 AEST; 15min ago
     Docs: man:systemd-vconsole-setup.service(8)
 Main PID: 452 (code=exited, status=0/SUCCESS)

Dec 20 18:29:55 fusion809-OT-pc systemd[1]: Started Setup Virtual Console.

My /etc/vconsole.conf is here:


because I changed it post-install, when it was first installed it was KEYMAP=gb.

Thanks for your time,

And yes I have rebooted a couple of times since the change from the gb keymap in /etc/vconsole.conf to a us one. Still the keymap the system seems to be using is gb.

Well changing the keymap used for most apps is simple to set using YaST it’s the systemd-vconsole-setup failure that upsets me now.

This is odd, after changing it with YaST it seems to revert back very quickly.

Reading through the online versions of the MAN pages that should be read beginning with the MAN pages for systemd-vconsole-setup.service,

I read the following in order…

Note the possibly important line in the vconsole.conf MAN page

/etc/vconsole.conf is usually created and updated using systemd-localed.service(8). localectl(1) may be used to instruct systemd-localed.service to query or update configuration.

I don’t know for sure if openSUSE uses the systemd.localed.service but it’s a good bet that is the case which would mean that if you don’t make your changes through systemd-localed.service then your changes to vconsole.conf may be over-written or not read properly.

It may also not be an issue that systemd-vconsole-setup.service is dead because that service may be active only when needed, and then de-activated again afterwards. The important thing is that you’re not getting a “Failed” state.

Speculating because I haven’t had a need for this personally,

Seems to be fixed now. I just had to set my GNOME user account settings to favour the US keyboard input source and use localectl, so thanks.