systemd hibernate does not seem to work correclty


I’m trying to hibernate my desktop PC (a homemade clone using Asus P5B motherboard). Whether I use a command-line systemd hibernate or click the command from KDE menu, the system hibernates and then after a few seconds it wakes up and resumes (most of the cases :wink: ). At the same time, clicking a shutdown icon or using *systemd poweroff *succesfully turns the system off, and it does not wake up or boot Why does the system wake up in the first place and resumes rather than staying turned off, like after a “poweroff” command? I have all possible wake-up events turned off in BIOS. How can I fix this behavior?

The issue does not seem to be related to a particular opensuse version - I’ve had 42.1 for some time and it behaved in exactly the same way. Then I upgraded to 42.3 and it did not help. I changed a graphic card for a reason, and it did not help either.

Thank you very much for your help.



if your system comes back then i would imagine journalctl will give to a blow by blow account of the hibernation and possibly some clues as to the unprovoked wake up? If you have swap enabled perhaps comment if suspend works correctly.

Unfortunately, I didn’t see anything specific in the log. Suspend also wakes up by itself.

Check the UEFI/BIOS settings for sleep mode or similar.

What does the following report?

dmidecode -t bios