Systemd and ntp

I’m using 11.4 in a multiboot setup with Windows 7 and 11.3 (I installed 11.4 in its own partition and then added it to GRUB in 11.3).

I wanted to try systemd so added it to 11.4.

If I boot with systemV init then ntp starts and sets time correctly.

If I boot with systemd then it all starts fine but the clock is an hour slow but still claims to be in BST. If I go into settings and set locale without changing value it corrects the time.

(Because of Windows the system clock is set to local time).

11.3 and Windows all have the correct time.

Any ideas?

On 2011-04-14 13:36, tweetiepooh wrote:

> Any ideas?


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Is one set for daylight savings time the other is not? How about the HW clock?

As far as I know the settings are the same in all.

HW clock is set to local time (Windows forces this)

Timezone is set to Europe/London which I’d guess automatically compensates for daylight saving on the appropriate dates.

11.4$ date
time one hour ago BST

11.3$ date
time now BST

On 2011-04-15 09:36, tweetiepooh wrote:

To me it looks like a bug you should report in bugzilla. It can not be that
using systemv or systemd makes different times.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

There are timing errors between Win and Linux and there’s a timezone fix from Win 7 that I don’t have the link for at the moment. It updates the timezones.

Starting out I’d set other system clocks (including the BIOS) to the same timezones, UTC and DST as OS 11.3. Use the same NTP Internet time providers as 11.3. Because you have 3 systems on the same machine I don’t think its a BIOS clock issue (HW clock) even though systems update the HW clock when rebooting.