systemd 210 update error

Few days ago the update repo pushed updates for systemd and udev to version 210…this hosed a virtualbox guest that I had running. Pressed for time I restored from backup and came back to it where I found that the newest version of systemd had installed a file…/usr/lib/tmpfiles.d/systemd-nologin.conf…which I had never had on this install before…it was not correct in syntax and caused a problem with systemd-tmpfiles-setup-dev.service resulting in boot failure.

this file has the line:

F! /run/nologin 0644 - - - “System is booting up. See pam_nologin(8)”

which fails because it is not an absolute path. Change to:

F! /var/run/nologin 0644 - - - “System is booting up. See pam_nologin(8)”

and everything works fine.

I find it curious that there is no mention of this elsewhere, but this is what got me straightened out.

Hope it helps somebody :slight_smile:

You didn’t describe the specific scenario what happened just prior to generating that error. Is this during the Host bootup or a Guest bootup, or possibly a Service (possibly Virtualbox) starting up? Or did your error display while an existing Guest was running (I should think unlikely)?

Could this be related to perhaps running Virtualbox with normal User permissions?

Oftentimes, if you extracted the error from a logfile, it’s useful to include a line immediately before the problem starts happening and if the error is non-critical a line or two after.


After updates today when starting a W7 VDI from VBox manager it aborted with an error message I don’t recall nor could find in vobx logs.

dmesg at the time shows:

[Fev 8 21:27] vboxdrv: ffffffffa10dc020 VMMR0.r0
  +0,481891] vboxdrv: ffffffffa11d5020 VBoxDDR0.r0
  +0,001519] vboxdrv: ffffffffa0015020 VBoxDD2R0.r0
  +0,041451] VirtualBox[28852]: segfault at 78 ip 00007f39de08f00a sp 00007ffe50ab4ae0 error 4 in[7f39ddfef000+17e000]
[Fev 8 21:29] vboxdrv: ffffffffa10dc020 VMMR0.r0
  +0,439745] vboxdrv: ffffffffa11d5020 VBoxDDR0.r0
  +0,001066] vboxdrv: ffffffffa0015020 VBoxDD2R0.r0
  +0,078940] vboxdrv: ffffffffa0025020 VBoxEhciR0.r0

However I tried opening the same machine again - previously it was suspended - and it worked, booting normally.

Then I tried suspending this VM and starting again, and also starting two other VMs, one suspended and the other in shut down state, AND ALL STARTED normally.

The systemd file does NOT have the /var… appended:

> cat /usr/lib/tmpfiles.d/systemd-nologin.conf
#  This file is part of systemd.
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

# See tmpfiles.d(5) and systemd-forbid-user-logins.service(5).
# This file has special suffix so it is not run by mistake.

F!** /run/nologin** 0644 - - - "System is booting up. See pam_nologin(8)"

So perhaps it is not the issue, apparently vbox fixed itself after the first run error. Weird.