System won't boot - Graphics driver issue

Greetings!

So here’s my problem:
I have OpenSUSE 12.3 (64-bit) installed with GRUB2 (BIOS version) and the system itself works fine (not counting this issue). However my Nvidia GeForce 9800GTX+ graphics card died just today, so I had to put my in my spare ATi Radeon X1050 to be able to use the computer. It’s all good, the computer itself works like it should, I can use Windows 7 just fine. However I cannot boot up OpenSUSE anymore! When I try a normal boot, it gets stuck on the plymouth splash. If I load either kernel with a normal boot or recovery mode, it still gets stuck trying to initialize the graphical user interface. This must be because I’m trying to load the system with the nvidia driver using an ati card. Okay, I understand, but how do I boot up the system, so that I can remove the unneeded nvidia drivers?
Under windows I would reach now for the good old safe mode. I’m guessing there’s something like that on linux too, either with or without a GUI, but how do I reach that?

I would appreciate the help with this, as well as how to remove the driver if it has to be done from bash.

Another minor issue, not relevant to the other one:
Every time I boot up the system, before plymouth appears, there are four lines written like:
ata4: device softreset failed
or something like that… now I know this is some sort of bug with my chipset (AMD 770/SB700), but how do I make it not show?

Did you you try boot to safe mode. Select advanced in Grub2 menu. then the second entry should be a safe boot ie using generic drivers.

And if that works (it should), remove the file /etc/X11/xorg.conf so the nvidia driver isn’t used anymore. (And then you should uninstall the nvidia driver)

I tried the entry with “(recovery)” behind it, but still got stuck at the same point… gonna try it again though…

If that does not work boot to a command line

Press ‘e’ at boot menu
find line starting with linux go to the end of that line (note it wrapews so actully shows on severl screen lines but it is a single line. go to the full end) easiest to press end key
add a space and a 3 press F10 to continu boot you should get to a command log in.

Log in as root remove the /etc/X11/xorg.conf file if it exists and run yast ( use the tab/arrows/space keys to navigate and select) in software management remove nvidia. stuff add the ATI/AMD repo then add the ATI driver.

That’s the right one, yes.
If it doesn’t work, press Ctrl+Alt+F1 to get to a text mode login and login there.
Then remove that xorg.conf:

sudo rm /etc/X11/xorg.conf

Then the normal boot will work again, hopefully.

Thanks for the replies.
I’ve been “working on it” meanwhile, and did the following:

Any more ideas? :\

You shouldn’t move /etc/X11/xorg.conf.d, move it back! That is needed.

Any more ideas? :\

startx not supported for users by default. And kdm has to be run as root.
Just reboot or type:

sudo init 3
sudo init 5

to get to the login screen.

openSUSE-12.3 on my old Dell Studio 1537 laptop (with radeon hd3450 hardware) would typically only boot with the radeon driver if I press < esc > when the plymouth screen appeared after grub, or if I used the boot code plymouth.enable=0

I don’t know if that approach will work for you. You need to figure out how to apply boot codes into grub2 (its not difficult) to apply such as a boot code.

I no longer have said laptop, … with my having a new Ultrabook, I gave away my Dell Studio 1537 (with the radeon hd3450) to a friend’s child who is in the last year of high school.

I moved back the xorg.conf.d but not he xorg.conf, so it should have been fine. Did reboot without recovery boot. It actually DID NOT get stuck at plymouth, but then when it switched resolution or something, the monitor switched off. Then when it switched back, it did reboot. Then when I tried booting again, it again got stuck at plymouth loading. It’s still stuck at “reached target graphical interface” in recover mode…

Then please try this:

  • Press the key ‘e’ on your keyboard at the boot menu
  • search for the line starting with “linux”
  • append “nomodeset” to the end of the line
  • Press F10 to boot

Does it work then?

Edit:
It would be good to have a look at the files /var/log/Xorg.0.log and /var/log/Xorg.0.log.old, maybe you could somehow post them?
Maybe login in text mode and copy them to your windows partition or something like that?

I tried it with x11failsafe and nomodeset too just now. I also got the log file.

Here’s the xorg.0.log: 26.150] X.Org X Server 1.13.2 Release Date: 2013-01-24 26.150] X P - Pastebin.com](http://pastebin.com/ZeFPB4mW)

By the way, on normal boot it just gets stuck on plymouth. The image is fully faded in already, but it doesn’t switch to the logon screen. I can however switch to bash easily and initiate a shutdown -r now command.

I wouldn’t want to reinstall the system, I spent days configuring, compiling stuff 'n all, it became sort of cozy. :3

EDIT:
I already did zypper remove nvidia* long ago, so the nvidia driver should have been purged.

Well, that Xorg.log was with nomodeset.
Somehow that failed. Seems like you’ve hit by that modesetting driver bug that got fixed a few days ago, but hasn’t been released as update yet.

Could you please boot again without “nomodeset” nor “x11failsafe” and post the /var/log/Xorg.0.log from that boot?

We will get it sorted without reinstall I think. I just can’t guess what’s happening on your system.:wink:

Unfortunately that’s a no-go. I tried to initiate a normal boot, however it got stuck in a half faded-in state on plymouth. It was a crash probably, as I couldn’t switch to bash.

Hm. Would pressing ESC during boot work? (that quits the splash screen)

Or you could disable plymouth by adding “plymouth.enable=0” to the boot options.

YES. “plymouth.enable=0” actually did the trick! I’m writing these lines from OpenSUSE. :slight_smile:

Now what to do to keep it this way?

And also, that device softreset bug would be nice to be resolved too…

Btw, as an added feature, this video card actually detects the proper resolutions and refresh rates for my 17" CRT, unlike my previous nvidia, so my eyes won’t pop out from flickering.

Anyhow, Thank You Very Much!

Glad to read that worked. As I noted, that boot code was necessary for my Dell Studio 1537 with Radeon HD-3450 graphics.

The exact menu in YaST where it can be added permanently depends a bit on whether your PC uses legacy grub, or grub2, or grub2 with UEFI BIOS. I am typing this on a PC with grub2 and UEFI BIOS so I likely have a different YaST boot loader menu. But in general you will find the location to permanently apply that boot code under something like:

yast -> system -> boot loader -> boot loader options …

Oh. Another plymouth bug then? Or radeon… It works fine here with my Radeon 9600 (and also the radeon driver).
But actually, oldcpu already suggested this in comment#9::wink:

You could also try “rd.plymouth=0” that would disable plymouth just in the initrd so the bootsplash would still be there, but that fixed a weird video problem for another user (was an intel/nvidia hybrid system).

Well, just enter YaST->System->Boot Loader and click on “Boot Loader Options”. You can add kernel line parameters there.

Or just uninstall the package “plymouth” and its dependencies.

Is your system up-to-date regarding online updates?

Well, the nvidia driver should have done that as well, but the xorg.conf prevents automatic configuration.

And also, that device softreset bug would be nice to be resolved too…

Don’t ask too much at once! :wink:
Well, I guess you should open a new thread for that…

Here they suggest:

Well, that’s normal and nothing to worry about.

And I don’t think there is a way to get rid of those messages.

I guess you don’t have an ata4?
Maybe adding “ide_core.noprobe=3.0 ide_core.noprobe=3.1” to the boot options would help then? (maybe not)

Found this: ata1: softreset failed (device not ready) [Archive] - FedoraForum.org
According to that you maybe could get rid of those messages by:

  • recompiling the kernel with CONFIG_SATA_PMP=n
  • add pci=nomsi to kernel command line (this was just a speculation though)
    Or:

For my ATA controller (NVIDIA MCP73) I managed to fix it by forcing ata driver to not do cable detection using libata.force=80c. I dont know if it will work for others.

Which gave me this idea: “libata.force=4:nosrst” to disable soft resets for ata4 (this is what the error is about, so I personally would try that first of all)

Well, in the end I decided not to get too much into it: the system works well now that I removed plymouth and I think it’s the wisest to not touch it, since it’s good. I’ll just look over that softreset stuff.

THANKS FOR THE HELP, EVERYONE!