System will freeze on Shut-Down

Hello openSuse-Community,

I’ve bought a Lenovo ideapad 100 14IBY (with an Intel N5430) to make my first steps into the world of Linux. However, I’m experiencing my first problems right away and I have no idea what might cause this.

Here’s the problem:
I’ve installed openSuse LEAP with KDE on the Laptop, basically not changing any of the presets (except saying yes to “prepare for suspend”) and everything seemed to work fine.
But when I want to shut down the laptop it will always freeze, showing the lines:

11.938748] kvm: disabled by bios
11.964968] kvm: disabled by bios
11.989035] kvm: disabled by bios

Welcome to openSUSE Leap 42.1 - Kernel 4.1.12-1-default (tty1).

Hint: Num Lock off

linux-8c0u login: _

At first, the “_” will flash for a few seconds but will eventually stop to do so.
I also seem to be unable to enter anything while it shows this screen.

This is really depressing for a first user experience, so I hope someone can point me towards the solution.
Any hint would be higly appreciated.

Have you fully updated?

I haven’t started any updates manually.

So yes you ran update or no you did not run updates?? Where you notified of updates and did not run??

Note we can not look over your shoulder so you need to explain things. If you say you did not manually run updates that includes the upate notifer since running the updates are fully optional. This is not Windows were anything is forced down your throat

Go to Yast software-update and get all the updates


as root run zypper up

I didn’t mean to be give underdone information. I really just wanted to point out that I did not start any updates myself (didn’t even think of that, so thanks) and I didn’t know whether or not updates have been installed automatically.

However, to do be able to make some clear statements I’ve reinstalled the OS from scratch again and fully updated through YaST.
The problem still persists with the exception that all the “… disabled by bios” lines are no longer displayed.

I think I can hear that the harddrive stops running when the login-cursor stops flashing so I guess that the shut-down itself works properly as far as it goes.
Could this be caused by a faulty graphics driver? (like it won’t stop sending the display signal even though the OS doesn’t give the command anymore)

How long did you wait? I see the same symptom in VM (not every time, I do not know what triggers it, and I am not even sure if this was TW or Leap), but it shuts down after some time. Presumably it is 90 seconds (default timeout for service start/stop).

Yesterday, before I’ve installed the updates, I’ve left it right next to me for about 30 to 45 minutes and it still didn’t turn off so I’ve switched it off myself by holding the power button.
After updating I’ve been waiting for only a few minutes before giving up and again switching it off the hard way.

When I didn’t even know that this problem exists it would just stay on until it runs out of power and (judging from what i described above) I’m pretty sure it would still do so.

Also sometimes an issue (13.2 and Leap 42.1) with an Lenovo G505s Laptop (AMD 4-core GPU + AMD dual-graphics).

Assuming that the current Leap 42.1 updates have been applied – including the kernel update – then I haven’t been plagued by this issue for the last week or so.

  • Yes, in January (2016) when I upgraded from 13.2 via “zypper dup” I experienced this issue, sometimes.

Yes, the issue being discussed here is annoying but, it’s also a consequence of (semi-) “bleeding edge” and modern hardware.And, if I dare mention it here, we’re sometimes the “gamma” Test Community. :wink:

So, please be aware that sometimes even “beginning to get used to Linux” users need the following keyboard commands to get out of this dilemma:

  • [Alt] + [SysRq] + [r] : Regain control of the keyboard and mouse.
  • and then either: [Alt] + [SysRq] + [o] : Shut down and power off.
  • or: [Alt] + [SysRq] + ** : Reboot **

“SysRq” is usually the key “PrtScr” located to the right of the Function keys F1-12.

Hi dcurtisfra,

I’ve tried the Alt+SysRq+R/O/B commands and while it seems to be a pretty ‘brutal’ way to shut the system down while it’s running, it doesn’t have any effect when the Laptop is at the point where it shows the login-thing and the cursor doesn’t flash anymore.
it seems to me that the OS is completely down but something ‘keeps telling’ the Laptop to show the message, preventing it from turning off.

Any further ideas?

Update: Alt+SysRq+O also doesn’t work (I might have been lucky on the first try).

Doing this will lead to the system being shut off but the screen will just freeze and then nothings happens anymore.

Hi euhawki,
then, the only way out is the extremely brutal power button pressed for about 30 seconds. >:)
Yes, yes, it seems to be brutal but, *NIX systems have a quite wonderful capability, possibly since the very beginning (1969) and definitely since the mid-1970’s:

  • any I/O queued for disk writes is completed as much as possible when the system loses power.

Which means, mostly (read almost always) there is no data loss due to power failures.
If anything nasty happened during the last breath taken by the system during the power failure then, the file system check performed automatically at the next reboot corrects/repairs any directory and end-of-file issues caused by the damage done during the last milliseconds of the power failure.

  • Nobody is perfect but, *NIX systems have been proven to be extremely reliable in this respect: I haven’t checked the figures but at a guess possibly five 9’s: 99.999%.

Best regards

It is probably some problem with the BIOS ACPI settings. Also is the CPU one of the NEW skylake processors??

Hello, I too have this exact same problem with a fresh install of leap, on an Intel dg33bu board w/e6300 1.86gb dual processor, 4gigs ddr2 800 and 80 gig seagate ata. I’ve installed all updates and have tried several suggestions but I still have to hard switch to turn off. It’s not a big deal, but I would like to see a fix in the future.