System Tray - Network Management


I have been having this problem that the network icon doesn’t show me the list of connections and I cannot choose and connect if I have more than one.
I work around by setting the connection i want to ‘connect automatically’.

I use mobile broadband and in there it crashes while adding new connections. All i’m able to do is edit the existing connection.

I think I’m using KNetworkManager (the default one) and it showed me a list of ISP when i created a connection for the first time only. No trace of it now a days.

Is there a way to fix this?

Although I haven’t dealt with multiple mobile connections personally, I’ve observed numerous threads in these forums which describe using other network managers with more capabilities than knetworkmanager.

Recommend a quick search, try some of those others.


Are you right-clicking on the tray icon, or left-clicking?

Your image is what I get with right-click. With left-click I get different information.

Note that I use the network manager plasmoid, rather than knetworkmanager. But I think they are not all that different in what they display.

Using knetworkmanager, I see no diff when I rt-click or lft-click


Go by what Tony says… I don’t find any difference if I right click or left click

To add to it … guys I had everything working fine.,… some thing went wrong somewhere and has not recovered…

And people… this is what I’m missing on my system

I have read a lot around the forum and I couldn’t find a solution. And please tell if me if you know why the application has to crash when i add new connections…

Thanks in advance of any help


after having problems with the kde-networkmanagement applet and mobile-broadband, i changed to nm-applet as described here:

openSUSE starter: Step 2. Need mobile broadband? Use the GNOME applet

You should print it to pdf, cause you loose network connection during installation.

Because the “Add to autostart” description doesn’t work i did it the following way:

Configure Desktop > Startup and shutdown > Add program > /usr/bin/nm-applet

In the following window choose

Application > Advanced Options > Check “Place in system tray”

After restart of kde, the gnome applet should appear, which is much more usable.

The downside is, that you have use “gnome-keyring” for master-pw instead of kwallet, it will ask for a new master-pw the first time you want to connect.

Regards, user2304.

Finally I’m home… got upgraded to 12.1 and everthing with network manager is running fine… got other issues though.