System Tray 'missing in action'

I am new to SUSe and KDE 4 but have been using Linux in various flavours for over 10 years. I have just installed the 64 bit version of openSUSE12.2. I have somehow messed up the bottom panel while playing around on the KDE desktop. In particular I have lost the system tray. One consequence of this is that I get an error message about there being no system tray so HP-LIP can’t start.

How do I re-enable the system tray or better yet re-set the bottom panel to it’s original default configuration?

You cannot easily reset just the bottom panel. But, you can readd the systray widget:

Right click in the panel, “unlock widgets” is necessary (don’t think so, otherwise you couldn’t have gotten rid of the systray), Add widget, search for “sys”, it should show up. Double click it, and it will be added on the complete right.

To arrange the widgets on the panel (which itself is a widget :slight_smile: ): right click in the panel, Panel settings. Now, if you hover your mouse over the panel, you can see the various widgets, like taskmanager, kicker, clock etc. Clicking one shows a crosshair, now drag it to it’s new location.

When you’re done, right click anywhere in the desktop and pick “Lock widgets”.

Thanks for the prompt response. I have actually fixed the problem by doing the following :

In a terminal

cd ~/.kde4/share/config
rm plasma-desktop-appletsrc

When I exit the terminal and re-start the computer the original, default, bottom panel is back just as it was when I installed SUSE

This is a modification of an answer on the KDE forums which I think referred to an earlier version of KDE4. That answer didn’t work but it pointed me in the right direction.

That works, but it throws away everything you modified in the desktopappearance.

I’ve never had a problem creating a new bottom panel

Just right-click the desktop, Add Panel > Default Panel

I have found on occasion it insists on placing it at the top of the screen, but found if I then ‘make’ a second default panel by repeating the process it appears at the bottom, then I just delete the one that placed itself at the top

Fortunately it was when I was trying to modify it that I ‘lost’ it so I just wanted it back without modifications. But I will keep your point in mind if it happens again. Thank you for taking the trouble to post.