System Tray in Plasma5 doesn't allow to hide or show icons

Hello to everybody who has interested in this thread!

After the last system update on the last week the system tray doesn’t allow me to choose whether always show or always hide any icon. I choose needed option, click apply and nothing is happening with the icons. Does anyone know any workaround of this bug?

I have sni-qt and xembed-sni-proxy installed. Installing libappindicator1 doesn’t fix my problem too.

I seem to remember someone else mentioning this problem, though I don’t remember which thread. I haven’t tried it myself.

I did just set “akregator” to alway remain visible. But I won’t know if that did anything until I finish reading all outstanding articles in “akregator”.

See here:

That is exactly what I need! Thank you!:slight_smile:
I made this change in
line #97 from

                (index) {


                (currentIndex) {

Should I tag the thread as [solved]?

That’s not necessary.

If you want to, you can add a “[solved]” or similar to the title though when replying.