System tray icons in kde 4.2 b2

I have just recently updated system with KDE 4.2 beta2 from KDE 4.1.3 while running openSUSE 11.0. I know that there are some bugs about this beta too.
But my problem is, that my system tray icons are not there, even the system tray is there.
Any work out on this.
Help will be appreciated.


Any ideas?
I am still stuck in problem.

I don’t have this problem, running on an old low-spec test machine. All I can think of is to manually add one by clicking on add widgets and scrolling to the bottom to pick what you want.

Thanks for the hint.
I have tried that too, also adding new system tray from widget.
but no luck. All it showing is a blank tray.

Try this: press



mv /home/*username/.kde4 .kde4old


(you .kde4 folder will have been re-named .kde4old) you will start a New session with default settings, you may be able to import SOME settings back, but be prepared to statt all over.

I have implement that line, all goes fine.
But the system tray again is blank. Desktop is cleaned. All settings gone, no worries about this but again system icons?
This thing make me crazy. The bad bad thing is that it is my office computer. I cannot proceed with any work now.

Is there a way to restore to old kde4.1.3.

When you ass a new Tray/Panel, it is blank. But the fact that a new .kde4 login came up blank is very odd.

Do you have kde3 installed? You could login there and work on your problem when you have a free moment.

Run yast from the CLI as su


Install kde3base

from the patterns

Thanks caf for your explanation.
By default it will be kde3.5.10 or old ones.

Add this repo (you did say you were using 11.0)

kde3 build service
Index of /repositories/KDE:/KDE3/openSUSE_11.0

Add the base and desktop patterns if you haven’t already
then update all in that new repo

Installing it now.

hellow, I have the same problem since KDE 4.1.86 and 87. The system tray is there but there is no icons. I have noticed, that not all packages where upgraded so i have manually done it - no effect either.

System: openSUSE 11.0 [64 bit]

Try to install the latest video drivers for your card (for nVidia 180.18 beta).

With nv or nvidia driver (180/173) still no effect :frowning:

Hi there,
same problem. My systray icons are transparent. Totally.
I’m on a 11.1 OpenSuSE, KDE version: 4.2.00 “release 97”.
There are also some other glitches: at each restart I get two of each widgets on my panel (two quick-launches, two task managers, two systrays). Also, my pager doesn’t work with compiz anymore (I mean with the Compiz’ desktop cube).
To take the blame off Compiz, I must add that in Metacity there are the exact same problems with the panel widgets.
Back to the transparent systray icons though, I found another odd thing: when I move the entire panel on another side of the screen, the icons are back to normal. Unfortunatelly, if I put the panel back to the bottom of the screen - they are gone once more.
Another detail: the glitch wasn’t there when I first installed KDE 4.2, but came with one subsequent update (sorry, I have no idea which one).

I have a similar problem with opensuse 11.1 64 bit. KDE 4.1.3.

The icons are there…but they don’t get changed. For example KMix icon doesn’t change when I MUTE sound.

Btw, is there an official update from KDE 4.1.3 to 4.2 ?

I had the same issue. An upgrade from qt 4.4.0 to 4.4.3 solved it.