System Tray Icons (and Function?) Changed in 13.1 KDE

Somehow I seem to have lost the original System Tray icons that appeared after I installed 13.1. There used to be a ladybug like icon for the software updater and the Clipboard icon was also different. I managed to add back a Software Updater widget, but it does not look like the ladybug that was originally there. It looks like I somehow installed a different system tray. Is there any way to get the original back?


configure desktop > workspace appearance > desktop theme

ensure you have openSUSE selected

try changing to a different theme and then back again to see if that restores things.

Much appreciated…that was it. Wish they were all that easy…

This thread is a bit old… long and short of my issue is I messed up the window manager and had to reinstall KDE and now I’m trying to get all the KDE openSUSE specific icons back and the ladybug is missing. I tried changing the theme to Air and then back to openSUSE custom and no ladybug. Any help is appreciated.

what is the ladybug icon for?
I have no ladybug icon.
What application / function is it associated with?
Where is it usually located (taskbar, system tray, launcher)?

The “ladybug” icon is the updater applet’s (Apper) system tray icon.
But by default it is hidden when there are no updates, so maybe that’s why you don’t see it?

Click on the small up-arrow in the right side of the system tray (just left of the clock) to see the hidden icons and it should be there.
You can also switch it to be always shown or always hidden in the system tray settings (right-click on that small up-arrow to reach them, and click on “Entries” there).
You can also enable/disable the update applet completely there.

ah, of course.
I don’t use apper (remove packagekit etc) so have rarely seen this icon. :slight_smile:

apper only show for me as a notification event when updates are available and does not seem to have an icon on the bar anymore.

Then you might have it disabled in the System Tray Settings. Make sure “Software Updates” is enabled there (“Display”->“Additional Elements”).
In that case Apper works just like in 12.3, i.e. there is no icon in the System Tray, but you get a standard notification when there are updates and clicking on “Review” will start Apper.

I am still on 12.3 rotfl!

So no icon


You could install the package “apper-plasmoid” though if you wanted to have it… :wink:
IIRC, it is even added to the System Tray automatically on the next login, if not you would have to enable it manually in the System Tray Settings.
(on 13.1 the plasmoid is part of the standard “apper” package, that’s why it is there by default)

Sweet! Got it back, I had to install apper-lang. Thanks everyone!

Hm, apper-lang should not be necessary, this only contains the translations.

Maybe you didn’t have apper installed? (Installing apper-lang would also pull in apper as a dependency)

Well Long and short of it is I messed everything up at one point and could only boot to IceWM so I had to reinstall KDE, and when I tried to have zypper add apper-plasmoid, it couldn’t find it but it said it recommended apper-lang and Poof- I got some update notifications.

When I installed 13.1 my System tray Icons were small and neatly packed in a double row … nice!
After a reboot the icons were full panel height and ‘oh-so-ugly’ … driving me nuts to find a solution.
Tried everything that has been proposed and more but the ugly KDE remains.

If there are any more ways out there that have positively worked for others I would be most appreciative.


This will depend on the panel height that you have set. Select ‘Unlock Widgets’ > ‘Panel Options’ > ‘Panel Settings’. As you increase panel height the icons should form into more rows.