System Tray Creation Too Late?

Am running 11.2/KDE on dual Athlon 32 bit. On startup the hplip device manager tries to place its icon in the system tray, but this fails with the message “No system tray detected on this system”. The system tray is not yet present, but appears moments later. If I wait until the system tray appears and then enter the console command “hp-toolbox”, the app successfully inserts itself into the tray.

Am aware of a similar problem posted by kannte on 13 Dec 2009, “System tray problems”, and have tried the suggested solution of removing the .hplip folder. Didn’t help.

Which KDE version?

Am using the 11.2 release version, 4.3.1-5.6.3

I don’t remember getting any such issues in 4.3.1. I ran that version for sometime and I had quite a few items in the system tray. But, you never know, Panel and System Tray underwent a lot of minor changes.

There are a lot of minor releases after that. I recommend you to update to at least 4.3.4 which is very stable.

How long have you been reusing your ~/.kde4 directory? Most of the times these phenomena point in the direction of old plasma/KDE4 settings.

I’m having a similar issue which started when I added mounted network drives to fstab. They’re usually spun down and take while to come to life which delays the boot process, often (not always) with the consequences described above. Doesn’t bother me as I don’t coldboot that often.

Thanks to Knurpht for the suggestion re: .kde4. I deleted the entire contents of this folder, and the system tray creation problem went away. Unfortunately, though, I had to re-personalize the desktop.