System Time

I have a 64-bit laptop running opensuse 11.0. I’m having problem with system clock. It gets screwed up every time I reboot the box. It gets late even if I set it to a correct time before booting.>:(

$ dmesg | grep time

ATI board detected. Disabling timer routing over 8254.
time.c: Detected 1800.059 MHz processor.
Calibrating delay using timer specific routine… 3603.73 BogoMIPS (lpj=7207470)
…MP-BIOS bug: 8254 timer not connected to IO-APIC
Using local APIC timer interrupts.
APIC timer calibration result 12500453
Detected 12.500 MHz APIC timer.
Calibrating delay using timer specific routine… 3600.15 BogoMIPS (lpj=7200308)
AMD C1E detected late. Force timer broadcast.
evgpeblk-1052 [00] ev_initialize_gpe_bloc: Found 5 Wake, Enabled 3 Runtime GPEs in this block
PCI: Setting latency timer of device 0000:00:05.0 to 64
PCI: Setting latency timer of device 0000:00:06.0 to 64
PCI: Setting latency timer of device 0000:00:05.0 to 64
PCI: Setting latency timer of device 0000:00:06.0 to 64
PCI: Setting latency timer of device 0000:05:00.0 to 64

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

What are you rebooting to? If to windows then that’s your issue… most
OS’s set system time to GMT/UTC and windows sets is to local time. When
windows comes up it is resetting your clock using its server online (see
windows docs for how to configure this) and when Linux comes up it would
do the same, but as it follows the NTP standard it does not as your time
is almost certainly off by more than one thousand seconds (17-ish
minutes) and so it never changes it back until you do so manually.

You can also set Linux to use the hardware clock as “local time” instead
of UTC though that’s up to you.

Good luck.

bacon street wrote:
> I have a 64-bit laptop running opensuse 11.0. I’m having problem with
> system clock. It gets screwed up every time I reboot the box. It gets
> late even if I set it to a correct time before booting.>:(
>
> $ dmesg | grep time
>
> ATI board detected. Disabling timer routing over 8254.
> time.c: Detected 1800.059 MHz processor.
> Calibrating delay using timer specific routine… 3603.73 BogoMIPS
> (lpj=7207470)
> …MP-BIOS bug: 8254 timer not connected to IO-APIC
> Using local APIC timer interrupts.
> APIC timer calibration result 12500453
> Detected 12.500 MHz APIC timer.
> Calibrating delay using timer specific routine… 3600.15 BogoMIPS
> (lpj=7200308)
> AMD C1E detected late. Force timer broadcast.
> evgpeblk-1052 [00] ev_initialize_gpe_bloc: Found 5 Wake, Enabled 3
> Runtime GPEs in this block
> PCI: Setting latency timer of device 0000:00:05.0 to 64
> PCI: Setting latency timer of device 0000:00:06.0 to 64
> PCI: Setting latency timer of device 0000:00:05.0 to 64
> PCI: Setting latency timer of device 0000:00:06.0 to 64
> PCI: Setting latency timer of device 0000:05:00.0 to 64
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJj6tH3s42bA80+9kRAsEFAJ99CtN7TWY0T3y9twSmWOM2o5v9hwCeLcpB
C+Sl13OArOjA4QIovbP+8dU=
=TWku
-----END PGP SIGNATURE-----