System time issue

My main machine (11.2, KDE 4.4.2) has started to play up by changing the system time regularly. Seems to happen overnight, and no amount of correcting the time in System Settings> Date and Time seems to last. The timezone has been set correctly, locale too. It started the day we switched from summer to winter time, but early and by an excessive amount. Now it keeps changing the system time by something like nine hours. I know it’s not a battery issue as only the hours are affected, not the minutes.
Where do I begin to look? It seems like there’s an automatic internet time server interfering somewhere but I have no idea where to find it.

Is it a dual boot machine or purely Linux?

It’s a Windows-free machine (except for XP in Virtualbox - ahh, could it be that??? But I’ve had that for ages and it only started recently, and anyway XP does show the correct time…), triple booting Ubuntu 10.04, openSUSE 11.1 and 11.2. The issue occurrs only with 11.2, and started before the upgrade to KDE 4.4.2 (which I only did yesterday).

What servers do you have for the NTP service? Look in YaST.

Solved, by going into YaST>Date and Time and setting the clock to UTC (it was “local” while I was dual-booting with Windows until recently). Fingers crossed now!
Thanks for pointing me in the right direction, your mention of Windows reminded me why I had not used UTC…

Afraid it’s back… It’s 20:50 in Sydney now and it says 10:50.
I’m at my wits’ end, anyone have any further suggestions?

BIOS battery ?

To avoid all this, enable NTP when setting the time/date in Yast. More info, and the timeserver to use in your country: Home of the Network Time Protocol

Yes, the field in YaST for the NTP server was empty. I added a local one and synced, and the time is correct now. Hope it lasts this time.