System stops responding when YaST's "Hardware Information" applet scans for framebuffer devices

Whenever I start the “Hardware Information” applet in YaST, my system freezes when the applet starts scanning for framebuffer devices.

Here’s some system information I found on sysinfo:/.

OS Information
OS: Linux 2.6.34-12-desktop x86_64
Current user:
System: openSUSE 11.3 (x86_64)
KDE: 4.4.4 (KDE 4.4.4) “release 2”

CPU Information
Processor (CPU): Intel(R) Core™ i5 CPU M 450 @ 2.40GHz
Speed: 1,199.00 MHz
Cores: 4

Memory Information
Total memory (RAM): 3.7 GiB
Free memory: 2.8 GiB (+ 500.5 MiB Caches)
Free swap: 1.6 GiB

Display Info
Vendor: ATI Technologies Inc
Model: Mobility Radeon M93
2D driver: radeon
3D driver: R600 classic (7.8.2)

Battery Information
Battery present: yes
State: No Charge
Charge percent: 100%
Rechargeable: yes
AC plugged: yes

Is there any additional hardware information I have to post to help diagnose the problem? Is this a known issue? If so, is there a fix?

I guess the process of probing active graphics hardware can result in this kind of behaviour. Does this command do the same?

/usr/sbin/hwinfo --framebuffer

BTW, for more options

/usr/sbin/hwinfo --help

man hwinfo

Oddly enough, that doesn’t freeze up my system. I retried it several times - no problem whatsoever. I then launched Hardware Information to see if it still crashed. It did, this time while scanning for “USB”. I don’t know if it scanned for USB ports or connected USB devices, but I should mention that my iPod touch was hooked up to my laptop while I tried this.

Tomorrow I’ll try it again after disconnecting all USB devices, unless this can’t be part of the issue. Should I post lsusb output or something?

Here’s my hardware information as collected by Smolt:

I don’t know that I’d worry about it, unless the system is locking up under other conditions…

To probe evreything from CLI

/usr/sbin/hwinfo --all

Works smoothly. Could this be a YaST bug then?

pdedecker wrote:
> Works smoothly. Could this be a YaST bug then?

since what you describe is not routine, i guess more likely a setup
problem on your machine, or maybe a software conflict installed by
accident…enter the following into a terminal

zypper lr -d

and copy/paste the output back to this thread using the instructions

CAVEAT: [posted via NNTP w/openSUSE 10.3]
Programming: a race between software engineers building bigger/better
idiot-proof programs, and the universe building bigger/better idiots.
So far, the universe is winning. Rick Cook

pdedecker@linux-s6cn:~> zypper lr -d
# | Alias                               | Name                                | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service
1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes     | Yes     |   99     | rpm-md |                                           |        
2 | home:dheidler                       | home:dheidler                       | Yes     | Yes     |   99     | rpm-md |             |        
3 | home:lijews                         | home:lijews                         | Yes     | Yes     |   99     | rpm-md |               |        
4 | openSUSE-11.3 11.3-1.82             | openSUSE-11.3 11.3-1.82             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                                             |        
5 | openSUSE:Factory:Contrib            | openSUSE:Factory:Contrib            | Yes     | Yes     |   99     | rpm-md | |        
6 | repo-debug                          | openSUSE-11.3-Debug                 | Yes     | Yes     |   99     | yast2  |                      |        
7 | repo-non-oss                        | openSUSE-11.3-Non-Oss               | Yes     | Yes     |   99     | yast2  |                        |        
8 | repo-oss                            | openSUSE-11.3-Oss                   | Yes     | Yes     |   99     | yast2  |                            |        
9 | repo-source                         | openSUSE-11.3-Source                | No      | Yes     |   99     | NONE   |                     |        

Should I disable the homebrew repos? As far as I know there are no active software conflicts.

I’d disable the cd repo (#4), and the #s 2 and 3.

About software conflicts: no, not now, but that’s no guarantee that at the next attempt to install a program hell will not break loose :).

Woah… the problems just went away. That’s it… no more homebrew repos for me.:wink: