System stops after "Reached target Basic System." on AMD Ryzen 7 / B450

I used to have an old AMD Phenom 2 workstation and updated today to Ryzen 7 2700X on a Gigabyte B450 Aorus Pro Mainboard.

I tried to start the system from the old SSD first and it stopped right after entering the password for the encrypted volumes:

Please enter passphrase for disk Corsair_Force_3_SSD (cr_sdb3)! ************
[OK] Started Cryptography Setup for cr_sdb3
[OK] Reached target Encrypted Volumes.
[OK] Reached target System Initialization.
[OK] Reached target Basic System.

Starting with a Leap 15 Live usb stick has the same result, just as starting recovery mode: here is a photo of the recovery output

after some time (480 seconds, apparently), there is some additional output (link). I believe some driver is blocking the rest of the system.

I came across
Adding rd.break=initqueue to the kernel parameters does give me a working command line, but I’m lost there and don’t know how to continue.

I briefly tried the leap 15.1 alpha, the installer starts and shows the X11 based gui.
Kubuntu 18.04 starts up (but i’d prefer to keep my old data & yast)

Can anybody help?

Yes. This is module ccp (AMD Secure Processor driver). You could try passing modprobe.blacklist=ccp, it may help in ignoring it so you can proceed with boot.

Kubuntu 18.04 starts up (but i’d prefer to keep my old data & yast)

In this case you could add permanent blacklist to openSUSE.

In any case you should open bug report on openSUSE bugzilla. This is kernel bug.

oh, yes! it works. thanks

With change of hardware you should run mkinitrd to rediscover the hardware

I wouldn’t be able to run this without the system coming up. besides, the live version also didn’t work. i later installed tumbleweed on a spare disk. at first it worked but after an update it also stopped.

anyway, it’s resolved now :slight_smile:

btw, here is the bugzilla entry: (people might search for it)

Even so if the system runs you should still do a mkinitrd to be sure ALL the hardware is properly recognized. You could have run it via change root but the encryption would add a layer of complication.