System starts with F4 only

Tried to start system with secure-boot. No changes. Unable to fix it. Any help is highly appreciated, thank you all.

I don’t fully understand the question. Is F4 a BIOS key that you use during boot?

What’s the output from:

# efibootmgr -v

First of all, thanks for replying…
Yes F4 is the key to boot the system.

efibootmgr -v

Fatal: Couldn’t open either sysfs or procfs directories for accessing EFI variables.
Try ‘modprobe efivars’ as root.

modprobe efivars

nothing happened. Also restarted the sys, nothing changed

You made a mistake when installing.

You booted the install media in legacy mode, instead of booting it in EFI mode. As a result, opensuse is installed to boot in legacy mode.

I’ve got it! So, is there anything i can do to fix it, without re-installing the system? Thank you

Yes, but it isn’t easy. Reinstall is easier.

If you can boot the install media in UEFI mode to the rescue system, then you can mount everything and reinstall the boot loader.

If you want more details, post back.

Either way - to fix it or to reinstall, you need to boot the install media in UEFI mode. So maybe take a little time trying to find out if you can do that. How to do it depends on what the BIOS offers.

On one of my systems, I can hit F12 during boot, and it offers a list of UEFI boot options and a list of Legacy boot options.

On my other UEFI box, I have to set the BIOS to to prefer UEFI booting before I can force UEFI booting of the installer. Otherwise it boots legacy.

I’ll try to reboot and tap F12 and see what happens. I’ll let you know later. Many thanks indeed

[FONT=palatino linotype]*
No luck with F12. (It doesn’t work) - “I ran YAST Boot Loader mode” and i changed it to EFI BOOT instead of GRUB. Result none! The system still run thru F4 on booting. (BIOS is in EFI mode configuration…). Question: during the booting i have a warning concerning the Kernel Module and: “FAILED TO START LOAD A KERNEL MODULES”. I s there any relationship btwn them?
Sorry for bothering you but i am new on Linux… DON’T KICK ME OFF! Any help is welcome, thks


Are you able to boot the install media with UEFI?

Until you can do that, you won’t be able to switch your system to using UEFI.

Doing it with Yast will usually result in errors. Unless you are already booted in UEFI mode, the UEFI booting cannot be setup.

***I’m sorry, i have no clue on that.
****Can you explain how to do it to me, please

It depends on your BIOS. And I don’t have access to that.

Is there a way to set it to UEFI only? If there is, try that setting for booting the install media.

When you boot the install media with Legacy booting, there are function keys mentioned near the bottom of the screen (something like F3 for video, etc). When you boot with UEFI, you get a much plainer screen. (That’s to help you tell if you are able to get it right).

I’ll try, give me a chance… i’ll let u know. Appreciated

The BIOS does not support Either-Or. It is set to both Legacy and EFI. I can’t use them separately. The system only restarts with F4 and HDD but not in auto mode. GRUB2-EFI is set but
nothing changed, problem still remain unvaried. I think i’ll go to have some rest. That’s enough for today (01:40 AM in Europe now). Many many thanks for your support.
Any suggestions, i’m ready as soon as i get it to try. Thank you. Good night

Maybe try this:

Download the live rescue CD for opensuse 13.2. Burn it to a USB. See if you can boot the USB.

Then set your computer for secure-boot. See if you can still boot that USB.

If you can, it may be possible to modify the “grub.cfg” in the EFI partition of that USB to boot your installed system. And if we can somehow get your installed system booted in EFI mode, then it becomes easy to switch it to UEFI booting.