System speaker beeps continuos after hours

Hallo out tehre

I built up a system using opensuse 11.1

the systems main work is to be a smb server and a ftp server

if the system is started it runs perfectly but after nearly 10 or 12 hours running without any server or ftp action the systemspeaker permanently beeps

no error in errorlog and sensors are showing fine temperatures .
i tried 2 different boards (asus p5qlpro , msi p6mgm fd)
with different speed intel dual-core processors

somebody an idea ?


setterm -blength 0

Only if you’re sure its not trying to tell you something.

Welcome to the forums !!!

Did you use the same RAM on both the boards? If so, run memtest, or try some other RAM.

Don’t rely on temperature sensors too much, this wouldn’t be the first server I see that’s overheating, while reporting perfect temp values.
Also consider HDD temperature.

Edit: found some reports on failing PSU’s as well, though that sounds weird, power shortage after 10 hours.

Hi, yeah, welcome to the forums! (Sorry I didn’t say so before - my bad manners…)

Yeah I agree regarding the sensors. I fried an AMD chip quite recently (the cpu fan got caught on a stray IDE lead) & lm_sensors didn’t bat an eyelid.

Your bios might be able to tell you though. Unfortunately you can’t look at it while the OS is running so: When it beeps, turn it off & then back on real quick, then go into your bios & check the temps.

Is there a keyboard plugged in? Longshot but are you sure there isn’t a key stuck down? Something shorting the pins?

hi @all

no it is no keyboard error
and i several times did a fast jump to bios to take a look at temperatur every time between 35 and 40 degree celsius at that moment.
i see i didn’t wirte it : yes different boards with different CPUs and different memory

ok, powersupply may be a choice, i will try with another.

but it can’t be a matter of server load cause as i wrote: the error occurs if the server has NOTHING to work

i tried the following while beeping too:

accessing the server and using smb and accessing the server by login direcly and start some programs to generate load … it takes some seconds the beeping stops.

i think it ist depending on powermanagement but
the problem is the same with and without powermanagement package so maybe it belongs to kernelpowermanagement or saomething like this but i can’t find any clear information on it.


I guess maybe you could post a list of your running processes when the beeping happens, see if anyone here recognises something?

If it could be power management, is there an acpi log you can look through?